summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e4c61f4838c..f1f624339149 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = visual-studio-code-bin
pkgdesc = Visual Studio Code (vscode): Editor for building and debugging modern web and cloud applications (official binary version)
pkgver = 1.54.3
- pkgrel = 2
+ pkgrel = 3
url = https://code.visualstudio.com/
arch = x86_64
arch = i686
@@ -18,6 +18,7 @@ pkgbase = visual-studio-code-bin
depends = libxss
depends = glibc
depends = lsof
+ depends = shared-mime-info
optdepends = glib2: Needed for move to trash functionality
optdepends = libdbusmenu-glib: Needed for KDE global menu
provides = code
diff --git a/PKGBUILD b/PKGBUILD
index 6abeafd05e99..1d1156c0ff45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=visual-studio-code-bin
_pkgname=visual-studio-code
pkgver=1.54.3
-pkgrel=2
+pkgrel=3
pkgdesc="Visual Studio Code (vscode): Editor for building and debugging modern web and cloud applications (official binary version)"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url="https://code.visualstudio.com/"
@@ -11,7 +11,7 @@ license=('custom: commercial')
provides=('code')
conflicts=('code')
# lsof: need for terminal splitting, see https://github.com/Microsoft/vscode/issues/62991
-depends=(libxkbfile gnupg gtk3 libsecret nss gcc-libs libnotify libxss glibc lsof)
+depends=(libxkbfile gnupg gtk3 libsecret nss gcc-libs libnotify libxss glibc lsof shared-mime-info)
optdepends=('glib2: Needed for move to trash functionality'
'libdbusmenu-glib: Needed for KDE global menu')
source=(${_pkgname}.desktop ${_pkgname}-url-handler.desktop ${_pkgname}-workspace.xml)
@@ -60,8 +60,3 @@ package() {
ln -s /opt/${_pkgname}/bin/code "${pkgdir}"/usr/bin/code
}
-post_install() {
- if hash update-mime-database 2>/dev/null; then
- update-mime-database /usr/share/mime
- fi
-}