summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87c97be64ddf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vlan
+ pkgdesc = Virtual LAN configuration utility
+ pkgver = 1.9
+ pkgrel = 5
+ url = https://www.candelatech.com/~greear/vlan.html
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = https://www.candelatech.com/~greear/vlan/vlan.1.9.tar.gz
+ md5sums = 5f0c6060b33956fb16e11a15467dd394
+
+pkgname = vlan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceef09cda840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sébastien Luttringer
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=vlan
+pkgver=1.9
+pkgrel=5
+pkgdesc='Virtual LAN configuration utility'
+arch=('x86_64')
+url='https://www.candelatech.com/~greear/vlan.html'
+license=('GPL')
+depends=('glibc')
+source=("https://www.candelatech.com/~greear/vlan/vlan.$pkgver.tar.gz")
+md5sums=('5f0c6060b33956fb16e11a15467dd394')
+
+build() {
+ cd $pkgname
+ # don't call clean and all on the same line with -jn (with n > 0)
+ # there is a race condition, both target are launched at the same time
+ # and as upstream provide target nothing is built.
+ # don't use !makeflags in PKGBUILD options to not penalize building
+ make clean
+ make all
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 'vconfig' "$pkgdir/usr/bin/vconfig"
+ install -D -m755 'macvlan_config' "$pkgdir/usr/bin/macvlan_config"
+ install -D -m644 'vconfig.8' "$pkgdir/usr/share/man/man8/vconfig.8"
+}
+
+# vim:set ts=2 sw=2 et: