summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD28
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d6fd506f865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vlc-plugin-pipewire
+ pkgdesc = PipeWire audio plugins for VLC
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://www.remlab.net/vlc-plugin-pipewire/
+ arch = x86_64
+ license = GPL3
+ depends = vlc
+ depends = pipewire
+ source = https://www.remlab.net/files/vlc-plugin-pipewire/vlc-plugin-pipewire-v3.tar.xz
+ sha256sums = dba410b7c11f295a6ea228bffeef31cf534f659ade75d15e7134308577124e7b
+
+pkgname = vlc-plugin-pipewire
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b73905529f23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60490a960d10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: jmcb <joelsgp@protonmail.com>
+
+pkgname='vlc-plugin-pipewire'
+pkgver='3.0'
+_majorver="${pkgver%%.*}"
+pkgrel=1
+pkgdesc="PipeWire audio plugins for VLC"
+arch=('x86_64')
+url="https://www.remlab.net/vlc-plugin-pipewire/"
+license=('GPL3')
+depends=('vlc' 'pipewire')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+source=("https://www.remlab.net/files/${pkgname}/${pkgname}-v${_majorver}.tar.xz")
+sha256sums=('dba410b7c11f295a6ea228bffeef31cf534f659ade75d15e7134308577124e7b')
+
+build() {
+ cd "$pkgname-v$_majorver"
+ make
+}
+
+package() {
+ cd "$pkgname-v$_majorver"
+ make DESTDIR="$pkgdir/" install
+}