summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--Fix-build-using-old-GCC-intrinsics.patch292
-rw-r--r--PKGBUILD52
3 files changed, 36 insertions, 330 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3b4d11b377a..90c7a64a6a30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = vlc-qt5
- pkgdesc = A multi-platform MPEG, VCD/DVD, and DivX player (Qt5 version)
- pkgver = 2.2.4
+ pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player (Qt5 version)
+ pkgver = 2.2.6
pkgrel = 1
- url = http://www.videolan.org/vlc/
+ url = https://www.videolan.org/vlc/
arch = i686
arch = x86_64
license = LGPL2.1
@@ -87,19 +87,15 @@ pkgbase = vlc-qt5
provides = vlc
conflicts = vlc
options = !emptydirs
- backup = usr/share/vlc/lua/http/.hosts
- backup = usr/share/vlc/lua/http/dialogs/.hosts
- source = http://download.videolan.org/vlc/2.2.4/vlc-2.2.4.tar.xz
- source = http://download.videolan.org/vlc/2.2.4/vlc-2.2.4.tar.xz.asc
+ source = https://download.videolan.org/vlc/2.2.6/vlc-2.2.6.tar.xz
+ source = https://download.videolan.org/vlc/2.2.6/vlc-2.2.6.tar.xz.asc
source = update-vlc-plugin-cache.hook
source = lua53_compat.patch
- source = Fix-build-using-old-GCC-intrinsics.patch
validpgpkeys = 65F7C6B4206BD057A7EB73787180713BE58D1ADC
- md5sums = 55666c9898f658c7fcca12725bf7dd1b
- md5sums = SKIP
- md5sums = 6449d0d26bd34bca009eed58a4c20c83
- md5sums = 96d3b346d9149ffb1b430066dfb6249a
- md5sums = 61c8cfdf29668aa1f4a607f6bec6dfa8
+ sha512sums = 9aff5922eb8b3c6a24e6153c367b0170dbc67602ae3e9304f52d2da00c9081d66cc98abd722b7c95b6c7d2e6cc7c86f21f9cba42c7d4bf29ca97d0f2d3553f8d
+ sha512sums = SKIP
+ sha512sums = d9e69a01eb8868647beac0f419328e6ca3fe14a2e2a9e6ce4b61ed590b41b0136fb3ac9e284b174a910c2fe8822d1b37445a48d0b7caea647060ebfabe899e7b
+ sha512sums = 33cda373aa1fb3ee19a78748e2687f2b93c8662c9fda62ecd122a2e649df8edaceb54dda3991bc38c80737945a143a9e65baa2743a483bb737bb94cd590dc25f
pkgname = vlc-qt5
diff --git a/Fix-build-using-old-GCC-intrinsics.patch b/Fix-build-using-old-GCC-intrinsics.patch
deleted file mode 100644
index 7bfc0e6e10a1..000000000000
--- a/Fix-build-using-old-GCC-intrinsics.patch
+++ /dev/null
@@ -1,292 +0,0 @@
-From 8b0a359be21c8b66c7f7f5d34b85df3cf6689035 Mon Sep 17 00:00:00 2001
-From: Francois Cartegnie <fcvlcdev@free.fr>
-Date: Sun, 24 Jul 2016 12:59:20 +0200
-Subject: [PATCH] Fix build using old GCC intrinsics
-
-As the 2.2 headers are still using vlc_atomics (picture)
-we cannot have a way to avoid collisions with early
-or late <atomic> inclusion when using GCC >= 4.7
-
-Conditionals in vlc_atomic won't work.
-
-Happens in ProjectM and Qt5.
-
-Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
----
- modules/gui/qt4/actions_manager.cpp | 2 ++
- modules/gui/qt4/adapters/seekpoints.cpp | 4 +--
- modules/gui/qt4/adapters/seekpoints.hpp | 4 +--
- modules/gui/qt4/components/controller.cpp | 2 ++
- .../gui/qt4/components/playlist/playlist_model.hpp | 4 +--
- modules/gui/qt4/components/playlist/views.cpp | 6 ++++
- modules/gui/qt4/dialogs/messages.cpp | 2 ++
- modules/gui/qt4/dialogs/vlm.cpp | 4 ---
- modules/gui/qt4/dialogs/vlm.hpp | 4 ++-
- modules/gui/qt4/input_manager.cpp | 2 ++
- modules/gui/qt4/input_manager.hpp | 3 +-
- modules/gui/qt4/menus.cpp | 2 ++
- modules/gui/qt4/qt4.hpp | 32 ++++++++++++++++++----
- modules/gui/qt4/util/pictureflow.cpp | 2 ++
- modules/visualization/projectm.cpp | 4 +++
- 15 files changed, 56 insertions(+), 21 deletions(-)
-
-diff --git a/modules/gui/qt4/actions_manager.cpp b/modules/gui/qt4/actions_manager.cpp
-index eff40d9..b7ca967 100644
---- a/modules/gui/qt4/actions_manager.cpp
-+++ b/modules/gui/qt4/actions_manager.cpp
-@@ -25,6 +25,8 @@
- # include "config.h"
- #endif
-
-+#include "qt4.hpp"
-+
- #include <vlc_vout.h>
- #include <vlc_keys.h>
-
-diff --git a/modules/gui/qt4/adapters/seekpoints.cpp b/modules/gui/qt4/adapters/seekpoints.cpp
-index fbf2957..a3564bb 100644
---- a/modules/gui/qt4/adapters/seekpoints.cpp
-+++ b/modules/gui/qt4/adapters/seekpoints.cpp
-@@ -19,14 +19,12 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston MA 02110-1301, USA.
- *****************************************************************************/
-
-+#include "seekpoints.hpp"
-
- #include "recents.hpp"
- #include "dialogs_provider.hpp"
- #include "menus.hpp"
-
--#include "seekpoints.hpp"
--
--#include "qt4.hpp"
- #include "input_manager.hpp"
-
- SeekPoints::SeekPoints( QObject *parent, intf_thread_t *p_intf_ ) :
-diff --git a/modules/gui/qt4/adapters/seekpoints.hpp b/modules/gui/qt4/adapters/seekpoints.hpp
-index 0083989..bbb9214 100644
---- a/modules/gui/qt4/adapters/seekpoints.hpp
-+++ b/modules/gui/qt4/adapters/seekpoints.hpp
-@@ -22,9 +22,7 @@
- #ifndef SEEKPOINTS_HPP
- #define SEEKPOINTS_HPP
-
--#ifdef HAVE_CONFIG_H
--#include "config.h"
--#endif
-+#include "qt4.hpp"
-
- #include <vlc_common.h>
- #include <vlc_interface.h>
-diff --git a/modules/gui/qt4/components/controller.cpp b/modules/gui/qt4/components/controller.cpp
-index d93e0db..c43d929 100644
---- a/modules/gui/qt4/components/controller.cpp
-+++ b/modules/gui/qt4/components/controller.cpp
-@@ -26,6 +26,8 @@
- # include "config.h"
- #endif
-
-+#include "qt4.hpp"
-+
- #include <vlc_vout.h> /* vout_thread_t for FSC */
-
- /* Widgets */
-diff --git a/modules/gui/qt4/components/playlist/playlist_model.hpp b/modules/gui/qt4/components/playlist/playlist_model.hpp
-index f9d1d0c..1f71ac9 100644
---- a/modules/gui/qt4/components/playlist/playlist_model.hpp
-+++ b/modules/gui/qt4/components/playlist/playlist_model.hpp
-@@ -25,9 +25,7 @@
- #ifndef _PLAYLIST_MODEL_H_
- #define _PLAYLIST_MODEL_H_
-
--#ifdef HAVE_CONFIG_H
--# include "config.h"
--#endif
-+#include "qt4.hpp"
-
- #include <vlc_input.h>
- #include <vlc_playlist.h>
-diff --git a/modules/gui/qt4/components/playlist/views.cpp b/modules/gui/qt4/components/playlist/views.cpp
-index 59f6535..0066205 100644
---- a/modules/gui/qt4/components/playlist/views.cpp
-+++ b/modules/gui/qt4/components/playlist/views.cpp
-@@ -21,6 +21,12 @@
- * 51 Franklin Street, Fifth Floor, Boston MA 02110-1301, USA.
- *****************************************************************************/
-
-+#ifdef HAVE_CONFIG_H
-+#include "config.h"
-+#endif
-+
-+#include "qt4.hpp"
-+
- #include "components/playlist/views.hpp"
- #include "components/playlist/vlc_model.hpp" /* VLCModel */
- #include "components/playlist/sorting.h" /* Columns List */
-diff --git a/modules/gui/qt4/dialogs/messages.cpp b/modules/gui/qt4/dialogs/messages.cpp
-index 30793a2..9c79c99 100644
---- a/modules/gui/qt4/dialogs/messages.cpp
-+++ b/modules/gui/qt4/dialogs/messages.cpp
-@@ -24,6 +24,8 @@
- # include "config.h"
- #endif
-
-+#include "qt4.hpp"
-+
- #include "dialogs/messages.hpp"
-
- #include <QPlainTextEdit>
-diff --git a/modules/gui/qt4/dialogs/vlm.cpp b/modules/gui/qt4/dialogs/vlm.cpp
-index 0da88cc..595f015 100644
---- a/modules/gui/qt4/dialogs/vlm.cpp
-+++ b/modules/gui/qt4/dialogs/vlm.cpp
-@@ -23,10 +23,6 @@
- * Foundation, Inc., 51 Franklin street, Fifth Floor, Boston MA 02110-1301, USA.
- *****************************************************************************/
-
--#ifdef HAVE_CONFIG_H
--# include "config.h"
--#endif
--
- #include "dialogs/vlm.hpp"
-
- #ifdef ENABLE_VLM
-diff --git a/modules/gui/qt4/dialogs/vlm.hpp b/modules/gui/qt4/dialogs/vlm.hpp
-index a3c6e5d..dcf7110 100644
---- a/modules/gui/qt4/dialogs/vlm.hpp
-+++ b/modules/gui/qt4/dialogs/vlm.hpp
-@@ -25,8 +25,10 @@
- #ifndef QVLC_VLM_DIALOG_H_
- #define QVLC_VLM_DIALOG_H_ 1
-
-+#include "qt4.hpp"
-+
- #ifdef HAVE_CONFIG_H
--# include "config.h"
-+#include "config.h"
- #endif
-
- #ifdef ENABLE_VLM
-diff --git a/modules/gui/qt4/input_manager.cpp b/modules/gui/qt4/input_manager.cpp
-index fd45f4a..c50cb6c 100644
---- a/modules/gui/qt4/input_manager.cpp
-+++ b/modules/gui/qt4/input_manager.cpp
-@@ -30,6 +30,8 @@
- # include "config.h"
- #endif
-
-+#include "qt4.hpp"
-+
- #include "input_manager.hpp"
- #include "recents.hpp"
-
-diff --git a/modules/gui/qt4/input_manager.hpp b/modules/gui/qt4/input_manager.hpp
-index 7d3b76a..4fbecbb 100644
---- a/modules/gui/qt4/input_manager.hpp
-+++ b/modules/gui/qt4/input_manager.hpp
-@@ -29,9 +29,10 @@
- # include "config.h"
- #endif
-
-+#include "qt4.hpp"
-+
- #include <vlc_input.h>
-
--#include "qt4.hpp"
- #include "util/singleton.hpp"
- #include "adapters/variables.hpp"
-
-diff --git a/modules/gui/qt4/menus.cpp b/modules/gui/qt4/menus.cpp
-index 116e98c..46240b0 100644
---- a/modules/gui/qt4/menus.cpp
-+++ b/modules/gui/qt4/menus.cpp
-@@ -34,6 +34,8 @@
- # include "config.h"
- #endif
-
-+#include "qt4.hpp"
-+
- #include <vlc_common.h>
- #include <vlc_intf_strings.h>
- #include <vlc_vout.h> /* vout_thread_t */
-diff --git a/modules/gui/qt4/qt4.hpp b/modules/gui/qt4/qt4.hpp
-index 44d7db6..5aec957 100644
---- a/modules/gui/qt4/qt4.hpp
-+++ b/modules/gui/qt4/qt4.hpp
-@@ -29,12 +29,7 @@
- # include "config.h"
- #endif
-
--#include <vlc_common.h> /* VLC_COMMON_MEMBERS for vlc_interface.h */
--#include <vlc_interface.h> /* intf_thread_t */
--#include <vlc_playlist.h> /* playlist_t */
--
--#define QT_NO_CAST_TO_ASCII
--#include <QString>
-+#include <QtGlobal>
-
- #if ( QT_VERSION < 0x040600 )
- # error Update your Qt version to at least 4.6.0
-@@ -43,6 +38,31 @@
- #define HAS_QT47 ( QT_VERSION >= 0x040700 )
- #define HAS_QT5 ( QT_VERSION >= 0x050000 )
-
-+#if HAS_QT5
-+ #include <QtCore/qcompilerdetection.h>
-+ #if defined(Q_COMPILER_ATOMICS) && \
-+ ( __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 7 ) )
-+ #define VLC_ATOMIC_H
-+ #include <atomic>
-+ using namespace std;
-+ # define atomic_store(object,desired) \
-+ do { \
-+ *(object) = (desired); \
-+ __sync_synchronize(); \
-+ } while (0)
-+
-+ # define atomic_load(object) \
-+ (__sync_synchronize(), *(object))
-+ #endif
-+#endif
-+
-+#include <vlc_common.h> /* VLC_COMMON_MEMBERS for vlc_interface.h */
-+#include <vlc_interface.h> /* intf_thread_t */
-+#include <vlc_playlist.h> /* playlist_t */
-+
-+#define QT_NO_CAST_TO_ASCII
-+#include <QString>
-+
- enum {
- DialogEventTypeOffset = 0,
- IMEventTypeOffset = 100,
-diff --git a/modules/gui/qt4/util/pictureflow.cpp b/modules/gui/qt4/util/pictureflow.cpp
-index 9318953..a7e6a01 100644
---- a/modules/gui/qt4/util/pictureflow.cpp
-+++ b/modules/gui/qt4/util/pictureflow.cpp
-@@ -29,6 +29,8 @@
- THE SOFTWARE.
- */
-
-+#include "qt4.hpp"
-+
- #include "pictureflow.hpp"
-
- #include <QApplication>
-diff --git a/modules/visualization/projectm.cpp b/modules/visualization/projectm.cpp
-index e80fbf4..96d532d 100644
---- a/modules/visualization/projectm.cpp
-+++ b/modules/visualization/projectm.cpp
-@@ -30,6 +30,10 @@
- #endif
-
- #include <assert.h>
-+#if defined(__GNUC__) && \
-+ ( __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 7 ) )
-+ #define VLC_ATOMIC_H /* Ensure C atomics wont collide with old intrinsics */
-+#endif
-
- #include <vlc_common.h>
- #include <vlc_plugin.h>
---
-2.8.1
-
diff --git a/PKGBUILD b/PKGBUILD
index bc3bbd973c7b..bcdba23098e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
# Contributor: Martin Sandsmark <martin.sandsmark@kde.org>
pkgname=vlc-qt5
_pkgname=vlc
-pkgver=2.2.4
+pkgver=2.2.6
pkgrel=1
-pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player (Qt5 version)"
+pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player (Qt5 version)'
+url='https://www.videolan.org/vlc/'
arch=('i686' 'x86_64')
-url="http://www.videolan.org/vlc/"
license=('LGPL2.1' 'GPL2')
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy'
'sdl_image' 'libdvdnav' 'libtiger' 'lua' 'libmatroska'
@@ -52,33 +53,34 @@ optdepends=('avahi: for service discovery using bonjour protocol'
'qt5-base: for the GUI')
conflicts=($_pkgname)
provides=($_pkgname)
-backup=('usr/share/vlc/lua/http/.hosts'
- 'usr/share/vlc/lua/http/dialogs/.hosts')
options=('!emptydirs')
-source=("http://download.videolan.org/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.xz"{,.asc}
- update-vlc-plugin-cache.hook "lua53_compat.patch" "Fix-build-using-old-GCC-intrinsics.patch")
-validpgpkeys=(65F7C6B4206BD057A7EB73787180713BE58D1ADC) # VideoLAN Release Signing Key
-md5sums=('55666c9898f658c7fcca12725bf7dd1b'
- 'SKIP'
- '6449d0d26bd34bca009eed58a4c20c83'
- '96d3b346d9149ffb1b430066dfb6249a'
- '61c8cfdf29668aa1f4a607f6bec6dfa8')
+source=(https://download.videolan.org/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.xz{,.asc}
+ update-vlc-plugin-cache.hook
+ lua53_compat.patch)
+sha512sums=('9aff5922eb8b3c6a24e6153c367b0170dbc67602ae3e9304f52d2da00c9081d66cc98abd722b7c95b6c7d2e6cc7c86f21f9cba42c7d4bf29ca97d0f2d3553f8d'
+ 'SKIP'
+ 'd9e69a01eb8868647beac0f419328e6ca3fe14a2e2a9e6ce4b61ed590b41b0136fb3ac9e284b174a910c2fe8822d1b37445a48d0b7caea647060ebfabe899e7b'
+ '33cda373aa1fb3ee19a78748e2687f2b93c8662c9fda62ecd122a2e649df8edaceb54dda3991bc38c80737945a143a9e65baa2743a483bb737bb94cd590dc25f')
+validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
prepare() {
- cd "${_pkgname}-${pkgver}"
-
+ cd ${_pkgname}-${pkgver}
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
-
patch -p1 < "${srcdir}/lua53_compat.patch"
- patch -p1 < "${srcdir}/Fix-build-using-old-GCC-intrinsics.patch"
}
build() {
- cd "${_pkgname}-${pkgver}"
+ cd ${_pkgname}-${pkgver}
+
+ export PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig"
+ export CFLAGS+=" -I/usr/include/samba-4.0"
+ export CPPFLAGS+=" -I/usr/include/samba-4.0"
+ export CXXFLAGS+=" -std=c++11"
+ export LUAC=/usr/bin/luac
+ export LUA_LIBS="`pkg-config --libs lua`"
+ export RCC=/usr/bin/rcc-qt5
- PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig" \
- CFLAGS+=" -I/usr/include/samba-4.0" CPPFLAGS+=" -I/usr/include/samba-4.0" CXXFLAGS+=" -std=c++11" \
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
@@ -91,9 +93,7 @@ build() {
--enable-vcdx \
--enable-upnp \
--enable-opus \
- --enable-sftp \
- LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
- RCC=/usr/bin/rcc-qt5
+ --enable-sftp
make
}
@@ -104,9 +104,11 @@ package() {
make DESTDIR="${pkgdir}" install
for res in 16 32 48 128; do
- install -D -m644 "${srcdir}/vlc-${pkgver}/share/icons/${res}x${res}/vlc.png" \
+ install -Dm 644 "${srcdir}/vlc-${pkgver}/share/icons/${res}x${res}/vlc.png" \
"${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png"
done
- install -Dm644 "$srcdir"/update-vlc-plugin-cache.hook "$pkgdir"/usr/share/libalpm/hooks/update-vlc-plugin-cache.hook
+ install -Dm 644 "${srcdir}/update-vlc-plugin-cache.hook" -t "${pkgdir}/usr/share/libalpm/hooks"
}
+
+# vim: ts=2 sw=2 et: