summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 753338546cab..638641aafbe9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = voc-git
depends = make
depends = diffutils
optdepends = clang
- source = src::git+https://github.com/vishaps/voc
+ source = voc-git::git+https://github.com/vishaps/voc
md5sums = SKIP
pkgname = voc-git
diff --git a/PKGBUILD b/PKGBUILD
index 4558ebbe5523..3853eecfc65d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ license=('GPL3')
makedepends=('git')
depends=('gcc' 'make' 'diffutils')
optdepends=('clang')
-source=('src::git+https://github.com/vishaps/voc')
+source=("$pkgname::git+https://github.com/vishaps/voc")
md5sums=('SKIP')
install=$pkgname.install
@@ -17,10 +17,12 @@ install=$pkgname.install
# backend=clang
pkgver() {
+ cd $pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
+ cd $pkgname
if [ "$backend" == "clang" ]
then
export CC=clang
@@ -29,6 +31,7 @@ build() {
}
package() {
+ cd $pkgname
mkdir -p "$pkgdir/opt/voc"
cp -Rfp install/* "$pkgdir/opt/voc"
mkdir -p "$pkgdir/usr/bin"