summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26a4ca7807b0..3064d46fd091 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by makepkg 4.2.1
-# Wed Apr 22 17:22:11 UTC 2015
pkgbase = voxelshop
pkgdesc = VoxelShop is an extremely intuitive and powerful cross-platform software to modify and create voxel objects was designed from the ground up in close collaboration with artists.
- pkgver = 1.7.01
+ pkgver = 1.8.02
pkgrel = 1
url = http://blackflux.com/node/11
- arch = i686
- arch = x86_64
- license = Free
+ arch = any
+ license = custom
depends = java-runtime-common
source = voxelshop
- source = http://blackflux.com/software/vs/download/?file=VoxelShop.zip
+ source = https://github.com/simlu/voxelshop/releases/download/1.8.02/VoxelShop-java-all-os-fast.zip
sha256sums = 69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa
sha256sums = 86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3
diff --git a/PKGBUILD b/PKGBUILD
index 6f4a0315ac8f..5cb9e9b7e03e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Andrew Dunai <andrew@dun.ai>
+# Co-maintainer: Damien Flament <damien.flament@gmx.com>
pkgname=voxelshop
_pkgname_upper=VoxelShop
pkgver=1.8.02
@@ -27,11 +28,17 @@ sha256sums=('69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa'
arch=('any')
package() {
- install -D ${pkgname} ${pkgdir}/usr/bin/${pkgname}
- ln -s ${pkgname} ${pkgdir}/usr/bin/${_pkgname_upper}
+ # Install the package startup script
+ install -D "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- cd ${srcdir}/${_pkgname_upper}
+ # Add a symlink to the startup script using the camel-cased package name
+ ln -s "${pkgname}" "${pkgdir}/usr/bin/${_pkgname_upper}"
+
+ # Install the distributed files in /opt
+ cd "${srcdir}/${_pkgname_upper}"
install -Dt "${pkgdir}/opt/${pkgname}" start-linux.sh
cp -R data "${pkgdir}/opt/${pkgname}"
+
+ # Install the license file
install -D License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}