summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
-rw-r--r--vpn-unlimited.install23
4 files changed, 29 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd47836b7683..5d32d8cbc52c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = vpn-unlimited
pkgdesc = VPN Unlimited client application
pkgver = 8.5.2
- pkgrel = 2
+ pkgrel = 4
url = https://www.vpnunlimitedapp.com
- install = vpn-unlimited.install
arch = x86_64
license = custom
- makedepends = patchelf
- depends = qt5-script
- depends = qt5-webkit
- depends = openvpn
- depends = openresolv
- depends = net-tools
+ depends = bash
+ depends = boost174-libs
depends = c-ares
+ depends = curl
+ depends = gcc-libs
+ depends = glibc
+ depends = hicolor-icon-theme
depends = lsb-release
- depends = strongswan
+ depends = lzo
+ depends = net-tools
+ depends = openresolv
+ depends = openvpn
+ depends = qt5-base
depends = qt5-webengine
- depends = openssl-1.1
+ depends = strongswan
depends = wireguard-tools
- depends = boost-libs=1.74.0
+ depends = zlib
source = https://geo.keepsolidcdn.com/soft/vpn/Linux/VPN_Unlimited_8.5.2_amd64_mint.deb
source = vpn-unlimited-daemon.service
source = vpn-unlimited.desktop
diff --git a/.gitignore b/.gitignore
index 2538258db459..fd6f5a70c247 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,3 @@
!.SRCINFO
!vpn-unlimited-daemon.service
!vpn-unlimited.desktop
-!vpn-unlimited.install
diff --git a/PKGBUILD b/PKGBUILD
index c3cd5550b620..3a2d59c1b3b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,30 @@
pkgname=vpn-unlimited
pkgver=8.5.2
-pkgrel=2
+pkgrel=4
pkgdesc="VPN Unlimited client application"
arch=(x86_64)
url="https://www.vpnunlimitedapp.com"
license=(custom)
-makedepends=(
- patchelf
-)
depends=(
- qt5-script
- qt5-webkit
- openvpn
- openresolv
- net-tools
+ bash
+ boost174-libs
c-ares
+ curl
+ gcc-libs
+ glibc
+ hicolor-icon-theme
lsb-release
- strongswan
+ lzo
+ net-tools
+ openresolv
+ openvpn
+ qt5-base
qt5-webengine
- openssl-1.1
+ strongswan
wireguard-tools
- boost-libs=1.74.0
+ zlib
)
-install=vpn-unlimited.install
source=(
"https://geo.keepsolidcdn.com/soft/vpn/Linux/VPN_Unlimited_${pkgver}_amd64_mint.deb"
@@ -41,7 +42,7 @@ sha256sums=(
package() {
tar --extract --file data.tar.gz --directory "$pkgdir"
- rm --recursive "$pkgdir/etc"
+ rm --recursive "${pkgdir:?}/etc"
find "$pkgdir/usr/sbin" -type f -exec mv '{}' "$pkgdir/usr/bin/" \;
rm -r "$pkgdir/usr/sbin"
@@ -56,15 +57,5 @@ package() {
chmod --recursive go-w "$pkgdir/usr"
- files=(
- $pkgdir/usr/bin/vpn-unlimited
- $pkgdir/usr/bin/vpn-unlimited-daemon
- $pkgdir/usr/lib/libvpnu_private_sdk.so.1.0.0
- )
- for file in "${files[@]}"; do
- patchelf --replace-needed libcrypto.so.3 libcrypto.so.1.1 "$file"
- patchelf --replace-needed libssl.so.3 libssl.so.1.1 "$file"
- done
-
install -Dm644 "vpn-unlimited-daemon.service" "$pkgdir/usr/lib/systemd/system/vpn-unlimited-daemon.service"
}
diff --git a/vpn-unlimited.install b/vpn-unlimited.install
deleted file mode 100644
index 4467f9fc271d..000000000000
--- a/vpn-unlimited.install
+++ /dev/null
@@ -1,23 +0,0 @@
-post_install() {
- echo "Enabling and starting vpn-unlimited-daemon.service ..."
- systemctl daemon-reload
- systemctl enable vpn-unlimited-daemon.service
- systemctl start vpn-unlimited-daemon.service
-}
-
-post_upgrade() {
- echo "Restarting vpn-unlimited-daemon.service ..."
- systemctl daemon-reload
- systemctl restart vpn-unlimited-daemon.service
-}
-
-pre_remove() {
- echo "Stopping and disabling vpn-unlimited-daemon.service ..."
- systemctl stop vpn-unlimited-daemon.service
- systemctl disable vpn-unlimited-daemon.service
-}
-
-post_remove() {
- echo "Running systemctl daemon-reload ..."
- systemctl daemon-reload
-}