summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5b1ac117b90..fc2a680d43eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,6 +35,8 @@ pkgbase = vscodium-git
conflicts = vscodium
conflicts = vscodium-bin
conflicts = vscodium-git
+ options = !strip
+ options = !debug
source = git+https://github.com/VSCodium/vscodium.git#branch=master
source = vscodium-git.desktop
source = vscodium-git-wayland.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 1b41612be4c2..bef2fd33efa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Free/Libre Open Source Software Binaries of VSCode (git build from late
arch=('x86_64' 'aarch64' 'armv7h')
url='https://github.com/VSCodium/vscodium.git'
license=('MIT')
-
+options=(!strip !debug)
depends=(
'fontconfig'
'libxtst'
@@ -142,6 +142,8 @@ build() {
# Disabling this patch, since it is for win32 and does not apply here
rm -rf patches/cleanup-archive.patch
+ # Same for ppc64le-support.patch since that is not a supported architecture
+ rm -rf patches/ppc64le-support.patch
. get_repo.sh
. build.sh
}