summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD65
-rw-r--r--vte-command-notify.patch (renamed from vte291-command-notify.patch)321
3 files changed, 167 insertions, 235 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0402da260975..868fe5b0d7da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vte3-notification
pkgdesc = Virtual Terminal Emulator widget for use with GTK3
- pkgver = 0.40.2
+ pkgver = 0.41.90
pkgrel = 1
url = http://www.gnome.org
arch = i686
@@ -11,23 +11,23 @@ pkgbase = vte3-notification
makedepends = gtk3
makedepends = vala
makedepends = gperf
- options = !emptydirs
- source = http://download.gnome.org/sources/vte/0.40/vte-0.40.2.tar.xz
- source = vte291-command-notify.patch
+ source = https://download.gnome.org/sources/vte/0.41/vte-0.41.90.tar.xz
source = add-zsh-notfication-support.patch
- sha256sums = 9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d
- sha256sums = c1d6be7fab5997a6908aac9f5864335293c4c1052847fdf10f406b54aacdc650
+ source = vte-command-notify.patch
+ sha256sums = f1ee9d27962c97414e09dfeb886efe437006f557b068f39330e0ff3a2c301516
sha256sums = 150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a
+ sha256sums = d88e870c6f2232e5a06ae4b45d6308aae5fa564f5b82dca460a743c71781eba4
pkgname = vte3-notification
depends = gtk3
depends = vte-notification-common
- provides = vte3=0.40.2
+ provides = vte3=0.41.90
conflicts = vte3
+ options = !emptydirs
pkgname = vte-notification-common
pkgdesc = Common files used by vte and vte3
depends = glibc
- provides = vte-common=0.40.2
+ provides = vte-common=0.41.90
conflicts = vte-common
diff --git a/PKGBUILD b/PKGBUILD
index 725f66ffdefc..125c39f4d5e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,55 +4,54 @@
pkgbase=vte3-notification
pkgname=(vte3-notification vte-notification-common)
-pkgver=0.40.2
+pkgver=0.41.90
pkgrel=1
pkgdesc="Virtual Terminal Emulator widget for use with GTK3"
arch=('i686' 'x86_64')
license=('LGPL')
-options=('!emptydirs')
makedepends=('intltool' 'gobject-introspection' 'gtk3' 'vala' 'gperf')
url="http://www.gnome.org"
-source=(http://download.gnome.org/sources/vte/${pkgver::4}/vte-$pkgver.tar.xz
- vte291-command-notify.patch
- add-zsh-notfication-support.patch)
-sha256sums=('9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d'
- 'c1d6be7fab5997a6908aac9f5864335293c4c1052847fdf10f406b54aacdc650'
- '150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a')
+source=("https://download.gnome.org/sources/vte/${pkgver::4}/vte-${pkgver}.tar.xz"
+ 'add-zsh-notfication-support.patch'
+ 'vte-command-notify.patch')
+sha256sums=('f1ee9d27962c97414e09dfeb886efe437006f557b068f39330e0ff3a2c301516'
+ '150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
+ 'd88e870c6f2232e5a06ae4b45d6308aae5fa564f5b82dca460a743c71781eba4')
prepare () {
- cd vte-$pkgver
+ cd "vte-${pkgver}"
- patch -p1 -i ../vte291-command-notify.patch
- patch -p1 -i ../add-zsh-notfication-support.patch
+ patch -p1 -i ../vte-command-notify.patch
+ patch -p1 -i ../add-zsh-notfication-support.patch
}
build() {
- cd "vte-$pkgver"
- ./configure --prefix=/usr --sysconfdir=/etc \
- --libexecdir=/usr/lib/vte \
- --localstatedir=/var --disable-static \
- --enable-introspection --enable-gnome-pty-helper
- make
+ cd "vte-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib/vte \
+ --localstatedir=/var --disable-static \
+ --enable-introspection --enable-gnome-pty-helper
+ make
}
package_vte3-notification(){
- depends=('gtk3' 'vte-notification-common')
- provides=(vte3=$pkgver)
- conflicts=(vte3)
- cd "vte-$pkgver"
- make DESTDIR="$pkgdir" install
-
- rm "$pkgdir"/usr/lib/vte/gnome-pty-helper
- rm "$pkgdir"/etc/profile.d/vte.sh
+ depends=('gtk3' 'vte-notification-common')
+ provides=("vte3=${pkgver}")
+ conflicts=('vte3')
+ options=('!emptydirs')
+
+ cd "vte-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}/etc/profile.d/vte.sh"
}
package_vte-notification-common() {
- pkgdesc="Common files used by vte and vte3"
- depends=('glibc')
- provides=(vte-common=$pkgver)
- conflicts=(vte-common)
- cd "vte-$pkgver"
-
- make -C gnome-pty-helper DESTDIR="$pkgdir" install
- install -Dm644 src/vte.sh "$pkgdir"/etc/profile.d/vte.sh
+ pkgdesc="Common files used by vte and vte3"
+ depends=('glibc')
+ provides=("vte-common=${pkgver}")
+ conflicts=('vte-common')
+
+ cd "vte-${pkgver}"
+ install -d "${pkgdir}/usr/lib/vte/gnome-pty-helper"
+ install -Dm644 src/vte.sh "${pkgdir}/etc/profile.d/vte.sh"
}
diff --git a/vte291-command-notify.patch b/vte-command-notify.patch
index b9ccf8b89ca4..75ad0186fcaf 100644
--- a/vte291-command-notify.patch
+++ b/vte-command-notify.patch
@@ -1,46 +1,40 @@
-From c4cc87d1fc82b20190ad1fc491385df8a75db848 Mon Sep 17 00:00:00 2001
-From: Debarshi Ray <debarshir@gnome.org>
-Date: Wed, 7 Jan 2015 16:01:00 +0100
-Subject: [PATCH 1/3] emulation: Add sequences and signals for desktop
- notification
-
-Add sequences
- OSC 777 ; notify ; SUMMARY ; BODY BEL
- OSC 777 ; notify ; SUMMARY BEL
- OSC 777 ; notify ; SUMMARY ; BODY ST
- OSC 777 ; notify ; SUMMARY ST
-
-that let terminal applications send a notification to the desktop
-environment.
-
-Based on Enlightenment's Terminology:
-https://phab.enlightenment.org/T1765
-
-https://bugzilla.gnome.org/show_bug.cgi?id=711059
----
- src/caps.c | 4 +++
- src/marshal.list | 1 +
- src/vte-private.h | 5 +++
- src/vte.c | 38 +++++++++++++++++++++++
- src/vteseq-n.gperf | 1 +
- src/vteseq.c | 90 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
- src/vteterminal.h | 3 +-
- 7 files changed, 141 insertions(+), 1 deletion(-)
-
-diff --git a/src/caps.c b/src/caps.c
-index b51882f..0fe0661 100644
---- a/src/caps.c
-+++ b/src/caps.c
-@@ -254,6 +254,8 @@ const char _vte_xterm_capability_strings[] =
+diff -rupN vte-0.41.90/src/app.vala vte-0.41.90-patched/src/app.vala
+--- vte-0.41.90/src/app.vala 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/app.vala 2015-09-15 19:38:39.999947051 +0200
+@@ -102,6 +102,8 @@ class Window : Gtk.ApplicationWindow
+ if (App.Options.object_notifications)
+ terminal.notify.connect(notify_cb);
+
++ terminal.notification_received.connect(notification_received_cb);
++
+ /* Settings */
+ if (App.Options.no_double_buffer)
+ terminal.set_double_buffered(true);
+@@ -511,6 +513,11 @@ class Window : Gtk.ApplicationWindow
+ set_title(terminal.get_window_title());
+ }
+
++ private void notification_received_cb(Vte.Terminal terminal, string summary, string? body)
++ {
++ print ("[%s]: %s\n", summary, body);
++ }
++
+ } /* class Window */
+
+ class App : Gtk.Application
+diff -rupN vte-0.41.90/src/caps.cc vte-0.41.90-patched/src/caps.cc
+--- vte-0.41.90/src/caps.cc 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/caps.cc 2015-09-15 19:22:53.058742000 +0200
+@@ -254,6 +254,8 @@ const char _vte_xterm_capability_strings
ENTRY(OSC "117" BEL, "reset-highlight-background-color")
ENTRY(OSC "118" BEL, "reset-tek-cursor-color")
ENTRY(OSC "119" BEL, "reset-highlight-foreground-color")
-+ ENTRY(OSC "777;%s;%s;%s" BEL, "send-notification")
-+ ENTRY(OSC "777;%s;%s" BEL, "send-notification")
++ ENTRY(OSC "777;%s;%s;%s" BEL, "send-notification")
++ ENTRY(OSC "777;%s;%s" BEL, "send-notification")
COMMENT(/* Set text parameters, ST-terminated versions. */)
ENTRY(OSC ";%s" ST, "set-icon-and-window-title") COMMENT(/* undocumented default */)
-@@ -289,6 +291,8 @@ const char _vte_xterm_capability_strings[] =
+@@ -289,6 +291,8 @@ const char _vte_xterm_capability_strings
ENTRY(OSC "117" ST, "reset-highlight-background-color")
ENTRY(OSC "118" ST, "reset-tek-cursor-color")
ENTRY(OSC "119" ST, "reset-highlight-foreground-color")
@@ -49,37 +43,39 @@ index b51882f..0fe0661 100644
COMMENT(/* These may be bogus, I can't find docs for them anywhere (#104154). */)
ENTRY(OSC "21;%s" BEL, "set-text-property-21")
-diff --git a/src/marshal.list b/src/marshal.list
-index 0276422..2c35c68 100644
---- a/src/marshal.list
-+++ b/src/marshal.list
+diff -rupN vte-0.41.90/src/marshal.list vte-0.41.90-patched/src/marshal.list
+--- vte-0.41.90/src/marshal.list 2015-05-12 14:32:16.000000000 +0200
++++ vte-0.41.90-patched/src/marshal.list 2015-09-15 19:23:57.632415651 +0200
@@ -1,4 +1,5 @@
VOID:INT,INT
VOID:OBJECT,OBJECT
+VOID:STRING,STRING
VOID:STRING,UINT
VOID:UINT,UINT
-diff --git a/src/vte-private.h b/src/vte-private.h
-index 43d2266..cbb9402 100644
---- a/src/vte-private.h
-+++ b/src/vte-private.h
-@@ -421,6 +421,11 @@ struct _VteTerminalPrivate {
- gboolean cursor_moved_pending;
- gboolean contents_changed_pending;
+diff -rupN vte-0.41.90/src/vte/vteterminal.h vte-0.41.90-patched/src/vte/vteterminal.h
+--- vte-0.41.90/src/vte/vteterminal.h 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/vte/vteterminal.h 2015-09-15 19:36:59.769458153 +0200
+@@ -78,6 +78,7 @@ struct _VteTerminalClass {
+ void (*child_exited)(VteTerminal* terminal, int status);
+ void (*encoding_changed)(VteTerminal* terminal);
+ void (*char_size_changed)(VteTerminal* terminal, guint char_width, guint char_height);
++ void (*notification_received)(VteTerminal* terminal, const gchar *summary, const gchar *body);
+ void (*window_title_changed)(VteTerminal* terminal);
+ void (*icon_title_changed)(VteTerminal* terminal);
+ void (*selection_changed)(VteTerminal* terminal);
+@@ -111,7 +112,7 @@ struct _VteTerminalClass {
+ void (*bell)(VteTerminal* terminal);
-+ /* desktop notification */
-+ gboolean notification_received;
-+ gchar *notification_summary;
-+ gchar *notification_body;
-+
- /* window name changes */
- gchar *window_title;
- gchar *window_title_changed;
-diff --git a/src/vte.c b/src/vte.c
-index d49fccd..8125633 100644
---- a/src/vte.c
-+++ b/src/vte.c
-@@ -8581,6 +8581,9 @@ vte_terminal_finalize(GObject *object)
+ /* Padding for future expansion. */
+- gpointer padding[16];
++ gpointer padding[15];
+
+ VteTerminalClassPrivate *priv;
+ };
+diff -rupN vte-0.41.90/src/vte.cc vte-0.41.90-patched/src/vte.cc
+--- vte-0.41.90/src/vte.cc 2015-08-20 14:27:19.000000000 +0200
++++ vte-0.41.90-patched/src/vte.cc 2015-09-15 19:32:38.601546927 +0200
+@@ -8898,6 +8898,9 @@ vte_terminal_finalize(GObject *object)
remove_update_timeout (terminal);
@@ -89,7 +85,7 @@ index d49fccd..8125633 100644
/* discard title updates */
g_free(terminal->pvt->window_title);
g_free(terminal->pvt->window_title_changed);
-@@ -10314,6 +10317,7 @@ vte_terminal_class_init(VteTerminalClass *klass)
+@@ -10630,6 +10633,7 @@ vte_terminal_class_init(VteTerminalClass
klass->child_exited = NULL;
klass->encoding_changed = NULL;
klass->char_size_changed = NULL;
@@ -97,33 +93,33 @@ index d49fccd..8125633 100644
klass->window_title_changed = NULL;
klass->icon_title_changed = NULL;
klass->selection_changed = NULL;
-@@ -10388,6 +10392,25 @@ vte_terminal_class_init(VteTerminalClass *klass)
+@@ -10703,6 +10707,25 @@ vte_terminal_class_init(VteTerminalClass
+ G_TYPE_NONE,
1, G_TYPE_INT);
- /**
-+ * VteTerminal::notification-received:
-+ * @vteterminal: the object which received the signal
-+ * @summary: The summary
-+ * @body: (allow-none): Extra optional text
-+ *
-+ * Emitted when a process running in the terminal wants to
-+ * send a notification to the desktop environment.
-+ */
-+ g_signal_new(I_("notification-received"),
-+ G_OBJECT_CLASS_TYPE(klass),
-+ G_SIGNAL_RUN_LAST,
-+ G_STRUCT_OFFSET(VteTerminalClass, notification_received),
-+ NULL,
-+ NULL,
-+ _vte_marshal_VOID__STRING_STRING,
-+ G_TYPE_NONE,
-+ 2, G_TYPE_STRING, G_TYPE_STRING);
++ /**
++ * VteTerminal::notification-received:
++ * @vteterminal: the object which received the signal
++ * @summary: The summary
++ * @body: (allow-none): Extra optional text
++ *
++ * Emitted when a process running in the terminal wants to
++ * send a notification to the desktop environment.
++ */
++ g_signal_new(I_("notification-received"),
++ G_OBJECT_CLASS_TYPE(klass),
++ G_SIGNAL_RUN_LAST,
++ G_STRUCT_OFFSET(VteTerminalClass, notification_received),
++ NULL,
++ NULL,
++ _vte_marshal_VOID__STRING_STRING,
++ G_TYPE_NONE,
++ 2, G_TYPE_STRING, G_TYPE_STRING);
+
-+ /**
+ /**
* VteTerminal::window-title-changed:
* @vteterminal: the object which received the signal
- *
-@@ -12396,6 +12419,16 @@ need_processing (VteTerminal *terminal)
+@@ -12720,6 +12743,16 @@ need_processing (VteTerminal *terminal)
return _vte_incoming_chunks_length (terminal->pvt->incoming) != 0;
}
@@ -131,16 +127,16 @@ index d49fccd..8125633 100644
+vte_terminal_emit_notification_received (VteTerminal *terminal)
+{
+ _vte_debug_print (VTE_DEBUG_SIGNALS,
-+ "Emitting `notification-received'.\n");
++ "Emitting `notification-received'.\n");
+ g_signal_emit_by_name (terminal, "notification-received",
-+ terminal->pvt->notification_summary,
-+ terminal->pvt->notification_body);
++ terminal->pvt->notification_summary,
++ terminal->pvt->notification_body);
+}
+
/* Emit an "icon-title-changed" signal. */
static void
vte_terminal_emit_icon_title_changed(VteTerminal *terminal)
-@@ -12443,6 +12476,11 @@ vte_terminal_emit_pending_signals(VteTerminal *terminal)
+@@ -12767,6 +12800,11 @@ vte_terminal_emit_pending_signals(VteTer
vte_terminal_emit_adjustment_changed (terminal);
@@ -152,20 +148,49 @@ index d49fccd..8125633 100644
if (terminal->pvt->window_title_changed) {
g_free (terminal->pvt->window_title);
terminal->pvt->window_title = terminal->pvt->window_title_changed;
-diff --git a/src/vteseq-n.gperf b/src/vteseq-n.gperf
-index f28625b..7ee43be 100644
---- a/src/vteseq-n.gperf
-+++ b/src/vteseq-n.gperf
-@@ -167,3 +167,4 @@ struct vteseq_n_struct {
+diff -rupN vte-0.41.90/src/vte.sh vte-0.41.90-patched/src/vte.sh
+--- vte-0.41.90/src/vte.sh 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/vte.sh 2015-09-15 19:37:40.379655627 +0200
+@@ -50,9 +50,11 @@ __vte_osc7 () {
+ }
+
+ __vte_prompt_command() {
++ local command=$(HISTTIMEFORMAT= history 1 | sed 's/^ *[0-9]\+ *//')
++ command="${command//;/ }"
+ local pwd='~'
+ [ "$PWD" != "$HOME" ] && pwd=${PWD/#$HOME\//\~\/}
+- printf "\033]0;%s@%s:%s\007%s" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
++ printf "\033]777;notify;Command completed;%s\007\033]0;%s@%s:%s\007%s" "${command}" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
+ }
+
+ case "$TERM" in
+diff -rupN vte-0.41.90/src/vteinternal.hh vte-0.41.90-patched/src/vteinternal.hh
+--- vte-0.41.90/src/vteinternal.hh 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/vteinternal.hh 2015-09-15 19:43:58.858195797 +0200
+@@ -367,6 +367,11 @@ public:
+ gboolean cursor_moved_pending;
+ gboolean contents_changed_pending;
+
++ /* desktop notification */
++ gboolean notification_received;
++ gchar *notification_summary;
++ gchar *notification_body;
++
+ /* window name changes */
+ gchar *window_title;
+ gchar *window_title_changed;
+diff -rupN vte-0.41.90/src/vteseq-n.gperf vte-0.41.90-patched/src/vteseq-n.gperf
+--- vte-0.41.90/src/vteseq-n.gperf 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/vteseq-n.gperf 2015-09-15 19:34:10.725313524 +0200
+@@ -168,3 +168,4 @@ struct vteseq_n_struct {
#"reset-mouse-cursor-foreground-color", VTE_SEQUENCE_HANDLER_NULL
"set-current-directory-uri", VTE_SEQUENCE_HANDLER(vte_sequence_handler_set_current_directory_uri)
"set-current-file-uri", VTE_SEQUENCE_HANDLER(vte_sequence_handler_set_current_file_uri)
+"send-notification", VTE_SEQUENCE_HANDLER(vte_sequence_handler_send_notification)
-diff --git a/src/vteseq.c b/src/vteseq.c
-index b2f4b7d..eb34848 100644
---- a/src/vteseq.c
-+++ b/src/vteseq.c
-@@ -2221,6 +2221,96 @@ vte_sequence_handler_return_terminal_id (VteTerminal *terminal, GValueArray *par
+diff -rupN vte-0.41.90/src/vteseq.cc vte-0.41.90-patched/src/vteseq.cc
+--- vte-0.41.90/src/vteseq.cc 2015-08-20 14:26:53.000000000 +0200
++++ vte-0.41.90-patched/src/vteseq.cc 2015-09-15 20:52:23.771616988 +0200
+@@ -2227,6 +2227,97 @@ vte_sequence_handler_return_terminal_id
vte_sequence_handler_send_primary_device_attributes (terminal, params);
}
@@ -189,7 +214,7 @@ index b2f4b7d..eb34848 100644
+ if (G_VALUE_HOLDS_STRING (value)) {
+ option = g_value_dup_string (value);
+ } else if (G_VALUE_HOLDS_POINTER (value)) {
-+ option = vte_ucs4_to_utf8 (terminal, g_value_get_pointer (value));
++ option = vte_ucs4_to_utf8 (terminal, (const guchar *)g_value_get_pointer (value));
+ } else {
+ goto out;
+ }
@@ -206,7 +231,7 @@ index b2f4b7d..eb34848 100644
+ if (G_VALUE_HOLDS_STRING (value)) {
+ str = g_value_dup_string (value);
+ } else if (G_VALUE_HOLDS_POINTER (value)) {
-+ str = vte_ucs4_to_utf8 (terminal, g_value_get_pointer (value));
++ str = vte_ucs4_to_utf8 (terminal, (const guchar *)g_value_get_pointer (value));
+ } else {
+ goto out;
+ }
@@ -237,7 +262,7 @@ index b2f4b7d..eb34848 100644
+ if (G_VALUE_HOLDS_STRING (value)) {
+ str = g_value_dup_string (value);
+ } else if (G_VALUE_HOLDS_POINTER (value)) {
-+ str = vte_ucs4_to_utf8 (terminal, g_value_get_pointer (value));
++ str = vte_ucs4_to_utf8 (terminal, (const guchar *)g_value_get_pointer (value));
+ } else {
+ goto out;
+ }
@@ -259,99 +284,7 @@ index b2f4b7d..eb34848 100644
+ g_free (option);
+}
+
++
/* Send secondary device attributes. */
static void
vte_sequence_handler_send_secondary_device_attributes (VteTerminal *terminal, GValueArray *params)
-diff --git a/src/vteterminal.h b/src/vteterminal.h
-index 08f3b8f..d6ba7e2 100644
---- a/src/vteterminal.h
-+++ b/src/vteterminal.h
-@@ -72,6 +72,7 @@ struct _VteTerminalClass {
- void (*child_exited)(VteTerminal* terminal, int status);
- void (*encoding_changed)(VteTerminal* terminal);
- void (*char_size_changed)(VteTerminal* terminal, guint char_width, guint char_height);
-+ void (*notification_received)(VteTerminal* terminal, const gchar *summary, const gchar *body);
- void (*window_title_changed)(VteTerminal* terminal);
- void (*icon_title_changed)(VteTerminal* terminal);
- void (*selection_changed)(VteTerminal* terminal);
-@@ -105,7 +106,7 @@ struct _VteTerminalClass {
- void (*bell)(VteTerminal* terminal);
-
- /* Padding for future expansion. */
-- gpointer padding[16];
-+ gpointer padding[15];
-
- VteTerminalClassPrivate *priv;
- };
---
-2.1.0
-
-
-From 7decbc150a5f6764c0b1778133247fe542622189 Mon Sep 17 00:00:00 2001
-From: Debarshi Ray <debarshir@gnome.org>
-Date: Thu, 29 Jan 2015 13:09:17 +0100
-Subject: [PATCH 2/3] vte.sh: Emit OSC 777 from PROMPT_COMMAND
-
-https://bugzilla.gnome.org/show_bug.cgi?id=711059
----
- src/vte.sh | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/vte.sh b/src/vte.sh
-index 2d211ca..1c0543b 100644
---- a/src/vte.sh
-+++ b/src/vte.sh
-@@ -50,9 +50,11 @@ __vte_osc7 () {
- }
-
- __vte_prompt_command() {
-+ local command=$(HISTTIMEFORMAT= history 1 | sed 's/^ *[0-9]\+ *//')
-+ command="${command//;/ }"
- local pwd='~'
- [ "$PWD" != "$HOME" ] && pwd=${PWD/#$HOME\//\~\/}
-- printf "\033]0;%s@%s:%s\007%s" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
-+ printf "\033]777;notify;Command completed;%s\007\033]0;%s@%s:%s\007%s" "${command}" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
- }
-
- case "$TERM" in
---
-2.1.0
-
-
-From f0f281dd333f8639eb6e8ddb40bea9c097483243 Mon Sep 17 00:00:00 2001
-From: Debarshi Ray <debarshir@gnome.org>
-Date: Thu, 22 Jan 2015 16:37:10 +0100
-Subject: [PATCH 3/3] vteapp: Add a test for the notification-received signal
-
----
- src/app.vala | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/src/app.vala b/src/app.vala
-index e102e46..cc22480 100644
---- a/src/app.vala
-+++ b/src/app.vala
-@@ -102,6 +102,8 @@ class Window : Gtk.ApplicationWindow
- if (App.Options.object_notifications)
- terminal.notify.connect(notify_cb);
-
-+ terminal.notification_received.connect(notification_received_cb);
-+
- /* Settings */
- if (App.Options.no_double_buffer)
- terminal.set_double_buffered(true);
-@@ -511,6 +513,11 @@ class Window : Gtk.ApplicationWindow
- set_title(terminal.get_window_title());
- }
-
-+ private void notification_received_cb(Vte.Terminal terminal, string summary, string? body)
-+ {
-+ print ("[%s]: %s\n", summary, body);
-+ }
-+
- } /* class Window */
-
- class App : Gtk.Application
---
-2.1.0
-