summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 776afe351069..4cc136e90b05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 25 03:39:32 UTC 2017
+# Thu May 11 19:21:24 UTC 2017
pkgbase = vte3-notification
pkgdesc = Virtual Terminal Emulator widget for use with GTK3 with Fedora patches
- pkgver = 0.48.2+2+g837cce9c
+ pkgver = 0.48.3
pkgrel = 1
url = https://wiki.gnome.org/Apps/Terminal/VTE
arch = i686
@@ -19,11 +19,11 @@ pkgbase = vte3-notification
depends = pcre2
depends = gnutls
options = !emptydirs
- source = git+https://git.gnome.org/browse/vte#commit=837cce9ced6bfe317cb97aeca171001da92cb3a1
- source = vte291-command-notify-scroll-speed.patch::http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/plain/vte291-command-notify-scroll-speed.patch?h=f26
+ source = git+https://git.gnome.org/browse/vte#tag=0.48.3
+ source = vte291-command-notify-scroll-speed.patch-d8ae8b98633dc0bbe18946b55ac89414bda09938::http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/plain/vte291-command-notify-scroll-speed.patch?h=f26&id=d8ae8b98633dc0bbe18946b55ac89414bda09938
source = add-zsh-notfication-support.patch
sha256sums = SKIP
- sha256sums = d32201c04d9f688195725bf76d7c618ae24178a2578da01c507d8216f082cf8e
+ sha256sums = e03c3ddaa240c9c997d89b8fac03ab5f0fa2d3160cf51a7a14c08a4e9e4df47c
sha256sums = 150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a
pkgname = vte3-notification
@@ -31,13 +31,13 @@ pkgname = vte3-notification
depends = pcre2
depends = gnutls
depends = vte-notification-common
- provides = vte3=0.48.2+2+g837cce9c
+ provides = vte3=0.48.3
conflicts = vte3
pkgname = vte-notification-common
pkgdesc = Common files used by vte and vte3
arch = any
depends = sh
- provides = vte-common=0.48.2+2+g837cce9c
+ provides = vte-common=0.48.3
conflicts = vte-common
diff --git a/PKGBUILD b/PKGBUILD
index 36262d145802..5ccb3c5c9a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase='vte3-notification'
pkgname=("${pkgbase}" 'vte-notification-common')
-pkgver=0.48.2+2+g837cce9c
+pkgver=0.48.3
pkgrel=1
pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora patches'
arch=('i686' 'x86_64')
@@ -14,29 +14,36 @@ license=('LGPL')
depends=('gtk3' 'pcre2' 'gnutls')
makedepends=('git' 'intltool' 'gobject-introspection' 'gtk-doc' 'vala' 'gperf' 'glade')
options=('!emptydirs')
+
# Fedora patches: http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='http://pkgs.fedoraproject.org/cgit/rpms/vte291.git'
_frepobranch='f26'
_fpatchfile='vte291-command-notify-scroll-speed.patch'
-_vtecommit=837cce9ced6bfe317cb97aeca171001da92cb3a1
+_fcommit='d8ae8b98633dc0bbe18946b55ac89414bda09938'
+
+# VTE source ref
+#_vtecommit='837cce9ced6bfe317cb97aeca171001da92cb3a1'
+_vtetag=${pkgver}
+
source=(
- "git+https://git.gnome.org/browse/vte#commit=$_vtecommit"
- "${_fpatchfile}::${_frepourl}/plain/${_fpatchfile}?h=${_frepobranch}"
+ #"git+https://git.gnome.org/browse/vte#commit=$_vtecommit"
+ "git+https://git.gnome.org/browse/vte#tag=$_vtetag"
+ "${_fpatchfile}-${_fcommit}::${_frepourl}/plain/${_fpatchfile}?h=${_frepobranch}&id=${_fcommit}"
'add-zsh-notfication-support.patch'
)
sha256sums=('SKIP'
- 'd32201c04d9f688195725bf76d7c618ae24178a2578da01c507d8216f082cf8e'
+ 'e03c3ddaa240c9c997d89b8fac03ab5f0fa2d3160cf51a7a14c08a4e9e4df47c'
'150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a')
-pkgver() {
- cd vte
- git describe --tags | sed 's/-/+/g'
-}
+#pkgver() {
+# cd vte
+# git describe --tags | sed 's/-/+/g'
+#}
prepare () {
cd "vte"
- patch -p1 -i "../${_fpatchfile}"
+ patch -p1 -i "../${_fpatchfile}-${_fcommit}"
patch -p1 -i '../add-zsh-notfication-support.patch'
NOCONFIGURE=1 ./autogen.sh