summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 637a270bf02a..730b593882c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waffle
pkgdesc = a library for choosing window system and OpenGL API at runtime
- pkgver = 1.7.2
+ pkgver = 1.8.0
pkgrel = 1
url = https://waffle.freedesktop.org
arch = x86_64
@@ -10,20 +10,19 @@ pkgbase = waffle
makedepends = mesa
makedepends = libxslt
makedepends = docbook-xsl
- makedepends = systemd
makedepends = wayland-protocols
depends = libx11
depends = libxcb
- depends = libudev.so
optdepends = libgl: for OpenGL or GLX support
optdepends = libgles: for GLES support
optdepends = libegl: for gbm, surfaceless, x11_egl or wayland support
optdepends = mesa: for gbm support
+ optdepends = libdrm: for gbm support
optdepends = wayland: for wayland support
- source = https://waffle.freedesktop.org/files/release/waffle-1.7.2/waffle-1.7.2.tar.xz
- source = https://waffle.freedesktop.org/files/release/waffle-1.7.2/waffle-1.7.2.tar.xz.asc
+ source = https://waffle.freedesktop.org/files/release/waffle-1.8.0/waffle-1.8.0.tar.xz
+ source = https://waffle.freedesktop.org/files/release/waffle-1.8.0/waffle-1.8.0.tar.xz.asc
validpgpkeys = 8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D
- sha256sums = f676195cfea58cc75ef2441c5616b2f1d5565a7d371a6aa655aff3cc67c7c2c9
+ sha256sums = 29f462b5ea93510f585ae59b09f1aef6f9bad7287c7b82a7e8bd88f766e3afc7
sha256sums = SKIP
pkgname = waffle
diff --git a/PKGBUILD b/PKGBUILD
index bcfabf73702d..2ae27160711c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
# Maintainer: Emil Velikov <emil.l.velikov@gmail.com>
-# Maintainer: Eric Engestrom <aur@engestrom.ch>
+# Contributor: Eric Engestrom <aur@engestrom.ch>
# Contributor: Ben Widawsky <ben@bwidawsk.net>
# Contributor: Chad Versace <chad.versace@linux.intel.com>
pkgname=waffle
-pkgver=1.7.2
+pkgver=1.8.0
pkgrel=1
pkgdesc='a library for choosing window system and OpenGL API at runtime'
arch=('x86_64')
url='https://waffle.freedesktop.org'
license=('BSD')
-depends=('libx11' 'libxcb' 'libudev.so')
+depends=('libx11' 'libxcb')
optdepends=('libgl: for OpenGL or GLX support'
'libgles: for GLES support'
'libegl: for gbm, surfaceless, x11_egl or wayland support'
'mesa: for gbm support'
+ 'libdrm: for gbm support'
'wayland: for wayland support')
-# XXX: systemd is a bit of a hack, in particular:
-# The Arch packaging splits the libudev.so in one package, with the build
-# aka headers/pkg-config in another.
-makedepends=('meson' 'xcb-proto' 'mesa' 'libxslt' 'docbook-xsl' 'systemd' 'wayland-protocols')
+makedepends=('meson' 'xcb-proto' 'mesa' 'libxslt' 'docbook-xsl' 'wayland-protocols')
source=(https://waffle.freedesktop.org/files/release/waffle-${pkgver}/waffle-${pkgver}.tar.xz{,.asc})
-sha256sums=('f676195cfea58cc75ef2441c5616b2f1d5565a7d371a6aa655aff3cc67c7c2c9'
+sha256sums=('29f462b5ea93510f585ae59b09f1aef6f9bad7287c7b82a7e8bd88f766e3afc7'
'SKIP')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D')
build() {
- arch-meson "$pkgname-$pkgver" build \
- --buildtype release \
- -D build-manpages=true \
- -D build-htmldocs=true \
+ local meson_args=(
+ --buildtype release
+ -D build-manpages=true
+ -D build-htmldocs=true
-D build-examples=false
+ )
+ arch-meson "$pkgname-$pkgver" build "${meson_args[@]}"
meson compile -C build
}