summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79913b6926bd..cf35ceef8e0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = wakeonlan
pkgdesc = Utility for waking up computers using UDP Wake-on-Lan packets
- pkgver = 0.41
- pkgrel = 5
+ pkgver = 0.42
+ pkgrel = 1
url = https://github.com/jpoliv/wakeonlan/
arch = any
license = GPL
depends = perl
options = docs
- source = https://github.com/jpoliv/wakeonlan/archive/wakeonlan-0.41.tar.gz
- md5sums = 80182e67cc1ce471463b18a16f5476c4
+ source = https://github.com/jpoliv/wakeonlan/archive/v0.42.tar.gz
+ sha512sums = 46ecc7106eefa0b993f0f59eb4e4a593fac7831dffee87c743a7bd757abf366258e99e1efc6742fb3992ee066cb4e280787d0bf3d2db7fb4c88be7c09452da81
pkgname = wakeonlan
-
diff --git a/PKGBUILD b/PKGBUILD
index 09ef336bf335..2b931152f1f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
# Contributor: Hyperair <hyperair@gmail.com>
pkgname=wakeonlan
-pkgver=0.41
-pkgrel=5
+pkgver=0.42
+pkgrel=1
pkgdesc="Utility for waking up computers using UDP Wake-on-Lan packets"
arch=('any')
url="https://github.com/jpoliv/wakeonlan/"
license=('GPL')
depends=('perl')
-source=("https://github.com/jpoliv/wakeonlan/archive/wakeonlan-$pkgver.tar.gz")
-md5sums=('80182e67cc1ce471463b18a16f5476c4')
+source=("https://github.com/jpoliv/wakeonlan/archive/v$pkgver.tar.gz")
+sha512sums=('46ecc7106eefa0b993f0f59eb4e4a593fac7831dffee87c743a7bd757abf366258e99e1efc6742fb3992ee066cb4e280787d0bf3d2db7fb4c88be7c09452da81')
options=(docs)
build() {
- cd $srcdir/$pkgname-$pkgname-$pkgver
+ cd $srcdir/$pkgname-$pkgver
perl Makefile.PL
make
}
package() {
- cd $srcdir/$pkgname-$pkgname-$pkgver
+ cd $srcdir/$pkgname-$pkgver
install -D -m0755 $pkgname $pkgdir/usr/bin/$pkgname
install -D -m0644 blib/man1/$pkgname.1p $pkgdir/usr/share/man/man1p/$pkgname.1p
find examples -exec install -D -m0644 '{}' $pkgdir/usr/share/doc/$pkgname/\{\} \;