summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b989638af2f9..83d7856af692 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wallock-git
pkgdesc = wallock is a wallpaper and lock screen that enables macos like lock screens and wallapers on wayland. It is designed to work with wlroots based wayland compositors (sway, hyprland, etc..).
- pkgver = r22.651c017
+ pkgver = r41.6bf9f5e
pkgrel = 1
url = https://github.com/dpayne/wallock
arch = any
@@ -20,6 +20,7 @@ pkgbase = wallock-git
depends = mesa
provides = wallock-git
conflicts = wallock-git
+ options = !debug
source = git+https://github.com/dpayne/wallock
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7fa434628d10..b4ca10375a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tuxx <tuxx@danktank.nl>
# Contributor: Tuxx <tuxx@danktank.nl>
pkgname=wallock-git
-pkgver=r22.651c017
+pkgver=r41.6bf9f5e
pkgrel=1
pkgdesc="wallock is a wallpaper and lock screen that enables macos like lock screens and wallapers on wayland. It is designed to work with wlroots based wayland compositors (sway, hyprland, etc..)."
arch=(any)
@@ -14,7 +14,7 @@ provides=("${pkgname}")
conflicts=("${pkgname}")
replaces=()
backup=()
-options=()
+options=('!debug')
install=
source=(git+"https://github.com/dpayne/wallock")
noextract=()
@@ -23,16 +23,15 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
-
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
cmake -DCMAKE_BUILD_TYPE=Release -B build
cmake --build build
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
DESTDIR="$pkgdir" cmake --install build
}