summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e48ffa7aeae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = watson
+ pkgdesc = A wonderful CLI to track your time!
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://tailordev.github.io/Watson/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-arrow
+ depends = python-click
+ depends = python-requests
+ options = !emptydirs
+ source = https://github.com/TailorDev/Watson/archive/1.2.0.tar.gz
+ sha256sums = 3ef29a44c12e1b05f7af8569f90fa4cf110d2bc74b75ccadb74c45bb8efaad80
+
+pkgname = watson
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37cf8f328be3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Miodrag Tokić
+
+pkgname=watson
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A wonderful CLI to track your time!'
+arch=('any')
+url="https://tailordev.github.io/Watson/"
+license=('MIT')
+groups=()
+depends=('python' 'python-arrow' 'python-click' 'python-requests')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+
+source=("https://github.com/TailorDev/Watson/archive/${pkgver}.tar.gz")
+sha256sums=('3ef29a44c12e1b05f7af8569f90fa4cf110d2bc74b75ccadb74c45bb8efaad80')
+
+build() {
+ cd "$srcdir/Watson-${pkgver}"
+ sed -i '/pytest-runner/d' requirements.txt
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/Watson-${pkgver}"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 644 watson.completion "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}