summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--setup.py.patch13
3 files changed, 7 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58967c1a0ff6..21e3208e3f68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = watson
pkgdesc = A wonderful CLI to track your time!
- pkgver = 1.5.2
- pkgrel = 3
+ pkgver = 1.6.0
+ pkgrel = 1
url = https://tailordev.github.io/Watson/
arch = any
license = MIT
@@ -11,10 +11,8 @@ pkgbase = watson
depends = python-click
depends = python-requests
options = !emptydirs
- source = watson-1.5.2.tar.gz::https://github.com/TailorDev/Watson/archive/1.5.2.tar.gz
- source = setup.py.patch
- sha256sums = 4285335ead5c772864f3750522571404133d76bbffb00f1e739e7dd6d96416ce
- sha256sums = 5c8c6882ed4ad90a79a20ef3e41cda7abadaff52219dee737de37920096017b4
+ source = watson-1.6.0.tar.gz::https://github.com/TailorDev/Watson/archive/1.6.0.tar.gz
+ sha256sums = 34d63592e0818c5779ee993e606f2fa8d6f449b94f0a824da5f34bf15472b1ac
pkgname = watson
diff --git a/PKGBUILD b/PKGBUILD
index ca8e5dfd69bb..85e7f51869c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Miodrag Tokić
pkgname=watson
-pkgver=1.5.2
-pkgrel=3
+pkgver=1.6.0
+pkgrel=1
pkgdesc='A wonderful CLI to track your time!'
arch=('any')
url='https://tailordev.github.io/Watson/'
@@ -13,18 +13,11 @@ options=(!emptydirs)
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/TailorDev/Watson/archive/$pkgver.tar.gz"
- "setup.py.patch"
)
sha256sums=(
- '4285335ead5c772864f3750522571404133d76bbffb00f1e739e7dd6d96416ce'
- '5c8c6882ed4ad90a79a20ef3e41cda7abadaff52219dee737de37920096017b4'
+ '34d63592e0818c5779ee993e606f2fa8d6f449b94f0a824da5f34bf15472b1ac'
)
-prepare() {
- cd "$srcdir/Watson-$pkgver"
- patch -N -p1 -i "$srcdir/setup.py.patch"
-}
-
build() {
cd "$srcdir/Watson-$pkgver"
diff --git a/setup.py.patch b/setup.py.patch
deleted file mode 100644
index 125016895664..000000000000
--- a/setup.py.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 13b4f87..89cf44f 100644
---- a/setup.py
-+++ b/setup.py
-@@ -32,7 +32,7 @@ def parse_requirements(requirements, ignore=('setuptools',)):
- pkg = line.strip()
- if pkg not in ignore:
- packages.add(pkg)
-- return packages
-+ return tuple(packages)
-
-
- setup(