summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2382babc7356..a61cecc8c8fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wcp-git
pkgdesc = wcp is an experiment in re-implementing something like the standard cp file copy tool. The goal is to be as fast as possible, and provide the best possible progress bar, by counting up the total copy size in parallel with running the copy.
- pkgver = 0.0.0.r0.e102349
+ pkgver = r86.e102349
pkgrel = 1
url = https://github.com/wheybags/wcp
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 82d4404dd1ff..4c2608aabbcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Daniel Chesters <daniel.chesters@gmail.com>
pkgname=wcp-git
-pkgver=0.0.0.r0.e102349
+pkgver=r86.e102349
pkgrel=1
pkgdesc="wcp is an experiment in re-implementing something like the standard cp file copy tool. The goal is to be as fast as possible, and provide the best possible progress bar, by counting up the total copy size in parallel with running the copy."
url="https://github.com/wheybags/wcp"
@@ -17,7 +17,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
#git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
- echo "0.0.0.r0.$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {