summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--README.md36
-rw-r--r--weatherspect.160
4 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fcc04c8f059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = weatherspect
+ pkgdesc = A weather simulator using ASCII animations
+ pkgver = 1.11
+ pkgrel = 2
+ url = http://robobunny.com/projects/weatherspect/html/
+ arch = any
+ license = GPL
+ depends = perl-term-animation
+ depends = perl-weather-underground
+ source = http://robobunny.com/projects/weatherspect/weatherspect_v1.11.tar.gz
+ source = weatherspect.1
+ sha512sums = 02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b
+ sha512sums = 0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5
+
+pkgname = weatherspect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b595eada8b7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Prurigro
+# Contributor: Lara Maia <lara@craft.net.br>
+
+pkgname=weatherspect
+pkgver=1.11
+pkgrel=2
+pkgdesc="A weather simulator using ASCII animations"
+arch=('any')
+url="http://robobunny.com/projects/weatherspect/html/"
+license=('GPL')
+depends=('perl-term-animation' 'perl-weather-underground')
+source=("http://robobunny.com/projects/${pkgname}/${pkgname}_v${pkgver}.tar.gz" "${pkgname}.1")
+sha512sums=('02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b' '0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5')
+
+package() {
+ install -Dm644 ${pkgname}.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -Dm755 ${pkgname}_v${pkgver}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..b170dab0f2e0
--- /dev/null
+++ b/README.md
@@ -0,0 +1,36 @@
+# WeatherSpect v1.11 #
+
+## Description ##
+
+WeatherSpect provides a reasonably accurate simulation of what the weather looks like outside, in ASCII art. It includes rain, snow, lightning, sleet, and hail. The windspeed and cloudiness are reflected in the velocity and quantity of clouds. There are trees that age, reproduce and die over the course of an hour, and a sun and moon that follow the actual sun and moonrise. There's also a dancing turtle.
+
+## Requirements ##
+
+You must have the Term::Animation module, which you can get from http://www.cpan.org. The Term::Animation module also requires the Curses module, which you can also get from CPAN.
+
+## Usage ##
+
+Before weatherspect will work, you have to create a config file for it. Running it with the -c option will prompt you for info to create a config file in ~/.weatherspect.
+
+ weatherspect -h: Print this help message
+ weatherspect -f <file>: Supply a config file to use instead of the default
+ weatherspect -c: Generate a config file
+
+While weatherspect is running, the following commands are available:
+
+ q: Quit
+ h: Toggle the help window
+ w: Toggle the detailed weather info window
+ d: Toggle the debug window
+ u: Force an update of weather data
+ r: Redraw. This will remove all objects and recreate them, probably in different places.
+
+## Credits ##
+
+by Kirk Baucom <kbaucom@schizoid.com> [http://www.robobunny.com](http://www.robobunny.com)
+
+* Kevin Ferree (http://chavo-one.com): All art in the code marked with 'kf'
+* Hayley Wakenshaw (http://www.bornsquishy.com/flump/index.html): All art in the code marked with 'hjw'
+* Joan Stark (http://www.geocities.com/SoHo/7373/): All art in the code marked with 'jgs'
+
+You can grep for ATTRIB in the code to get a list of credits for all the ASCII art.
diff --git a/weatherspect.1 b/weatherspect.1
new file mode 100644
index 000000000000..49bec70da754
--- /dev/null
+++ b/weatherspect.1
@@ -0,0 +1,60 @@
+.\" generated with Ronn/v0.7.3
+.\" http://github.com/rtomayko/ronn/tree/0.7.3
+.
+.TH "WEATHERSPECT" "" "May 2014" "" "weatherspect"
+.
+.SH "Description"
+WeatherSpect provides a reasonably accurate simulation of what the weather looks like outside, in ASCII art\. It includes rain, snow, lightning, sleet, and hail\. The windspeed and cloudiness are reflected in the velocity and quantity of clouds\. There are trees that age, reproduce and die over the course of an hour, and a sun and moon that follow the actual sun and moonrise\. There\'s also a dancing turtle\.
+.
+.SH "Requirements"
+You must have the Term::Animation module, which you can get from http://www\.cpan\.org\. The Term::Animation module also requires the Curses module, which you can also get from CPAN\.
+.
+.SH "Usage"
+Before weatherspect will work, you have to create a config file for it\. Running it with the \-c option will prompt you for info to create a config file in ~/\.weatherspect\.
+.
+.IP "" 4
+.
+.nf
+
+weatherspect \-h: Print this help message
+weatherspect \-f <file>: Supply a config file to use instead of the default
+weatherspect \-c: Generate a config file
+.
+.fi
+.
+.IP "" 0
+.
+.P
+While weatherspect is running, the following commands are available:
+.
+.IP "" 4
+.
+.nf
+
+q: Quit
+h: Toggle the help window
+w: Toggle the detailed weather info window
+d: Toggle the debug window
+u: Force an update of weather data
+r: Redraw\. This will remove all objects and recreate them, probably in different places\.
+.
+.fi
+.
+.IP "" 0
+.
+.SH "Credits"
+by Kirk Baucom \fIkbaucom@schizoid\.com\fR \fIhttp://www\.robobunny\.com\fR
+.
+.IP "\(bu" 4
+Kevin Ferree (http://chavo\-one\.com): All art in the code marked with \'kf\'
+.
+.IP "\(bu" 4
+Hayley Wakenshaw (http://www\.bornsquishy\.com/flump/index\.html): All art in the code marked with \'hjw\'
+.
+.IP "\(bu" 4
+Joan Stark (http://www\.geocities\.com/SoHo/7373/): All art in the code marked with \'jgs\'
+.
+.IP "" 0
+.
+.P
+You can grep for ATTRIB in the code to get a list of credits for all the ASCII art\.