summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
-rw-r--r--wee-slack-git.install28
3 files changed, 33 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed2fe1cc4ec..c3a81d7670f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = wee-slack-git
- pkgdesc = A WeeChat plugin for slack
- pkgver = 2.9.0
+ pkgdesc = A WeeChat plugin for Slack
+ pkgver = 2.10.2.r368.gedaad8b
pkgrel = 1
- url = https://github.com/wee-slack/wee-slack
- install = wee-slack-git.install
+ url = https://github.com/wee-slack/wee-slack/
arch = any
license = MIT
makedepends = git
- depends = python-websocket-client
- depends = weechat
- provides = wee-slack
conflicts = wee-slack
- source = git+https://github.com/wee-slack/wee-slack.git
- sha256sums = SKIP
+ source = git+https://github.com/wee-slack/wee-slack
+ sha512sums = SKIP
pkgname = wee-slack-git
+ depends = python-websocket-client
+ depends = weechat
diff --git a/PKGBUILD b/PKGBUILD
index bb1132e4b9fb..ea2b25b6026b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
-# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
-
-# For ISSUES, REQUESTS, and QUESTIONS:
-# https://github.com/sudoforge/pkgbuilds
-
pkgname=wee-slack-git
-pkgver=2.9.0
+pkgver=2.10.2.r368.gedaad8b
pkgrel=1
-pkgdesc="A WeeChat plugin for slack"
+pkgdesc='A WeeChat plugin for Slack'
+url='https://github.com/wee-slack/wee-slack/'
arch=('any')
-url="https://github.com/wee-slack/${pkgname%-git}"
license=('MIT')
-depends=(
- 'python-websocket-client'
- 'weechat'
+
+makedepends=(
+ 'git'
+)
+
+conflicts=(
+ 'wee-slack'
+)
+
+source=(
+ 'git+https://github.com/wee-slack/wee-slack'
+)
+
+sha512sums=(
+ 'SKIP'
)
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install=$pkgname.install
-source=("git+${url}.git")
-sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd wee-slack
+ git describe --long | sed 's/^v//;s/-/.r/;s/-/./g'
}
package() {
- cd "${srcdir}/${pkgname%-git}"
+ depends+=(
+ 'python-websocket-client'
+ 'weechat'
+ )
- # Install the plugin script
+ cd wee-slack
install -Dm644 wee_slack.py "${pkgdir}/usr/share/weechat/python/wee_slack.py"
-
- # Install the emoji tab completion dictionary
install -Dm644 weemoji.json "${pkgdir}/usr/share/weechat/weemoji.json"
-
- # Install the plugin license
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/wee-slack/LICENSE"
}
diff --git a/wee-slack-git.install b/wee-slack-git.install
deleted file mode 100644
index 514126a1f6c1..000000000000
--- a/wee-slack-git.install
+++ /dev/null
@@ -1,28 +0,0 @@
-_install_update_msg() {
-cat <<EOF
-
-
-To autoload wee-slack on start up, each user will need to symlink the plugin to
-the correct autoload folder:
-
- \$ ln -s /usr/share/weechat/python/wee_slack.py ~/.weechat/python/autoload/
-
-
-Previous versions of this package recommended creating symlinks in your local
-~/.weechat directory. These are no longer necessary, and their removal is
-recommended:
-
- \$ rm -f ~/.weechat/weemoji.json
- \$ rm -f ~/.weechat/python/wee_slack.py
-
-
-EOF
-}
-
-post_install() {
- _install_update_msg
-}
-
-post_upgrade() {
- _install_update_msg
-}