summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD51
-rw-r--r--wesnoth-1.12.appdata.xml11
-rw-r--r--wesnothd-1.12.service13
4 files changed, 50 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad5fbfcd6e97..d88fe2d6c3fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = wesnoth-1.12
pkgdesc = Turn-based strategy game on a fantasy world (oldstable)
pkgver = 1.12.6+dev
- pkgrel = 9
+ pkgrel = 13
url = https://www.wesnoth.org
+ arch = i486
arch = i686
+ arch = pentium4
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
makedepends = boost
makedepends = scons
@@ -24,14 +29,15 @@ pkgbase = wesnoth-1.12
depends = dbus
depends = fribidi
options = !emptydirs
+ source = wesnoth-1.12-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.12
source = wesnoth-1.12.desktop
source = wesnothd-1.12.tmpfiles.conf
source = wesnothd-1.12.service
source = wesnoth-1.12.appdata.xml
+ sha256sums = SKIP
sha256sums = f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877
sha256sums = 4d11e481ad8610bb2ad65290d2b3d1bf2d058485deaa9016325499b113e0f89f
- sha256sums = bbc1a80412d3e880d695cf0e818969da90c578501b455d0a6a81a45568cd8231
- sha256sums = e5b0bd418e97d5f8cfc9392045dc749941c71e9cf805ef6f343c318022088384
+ sha256sums = f8e20adabc0ecdbce23aed375ad9b28b616cebb0d261b3c6b8e576ccb61dcdae
+ sha256sums = 15a5aa798923defd3debad04379f654c60bcbd59cc238c09b15c546eff954a0a
pkgname = wesnoth-1.12
-
diff --git a/PKGBUILD b/PKGBUILD
index 54f927a1f48f..717465e51847 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer Severin Glöckner <severin.gloeckner@stud-htwk.leipzig.de>
+# Maintainer: Severin Glöckner <severin.gloeckner@stud-htwk.leipzig.de>
# This script contains as well instructions for other Linux systems.
-# Have a look what is done in the function(){…} below.
+# Have a look what is done in the build() and package() functions below.
+# Execute the same command which are used there.
-# On other systems, ignore the used variables like $pkgdir, $srcdir or $startdir
+# On other systems, ignore the used variables like $pkgdir and $srcdir.
# (there $pkgdir would be the same as an undefined variable (empty),
-# and $srcdir as well as $stardir would be the place where you have your files)
+# and $srcdir would be the place where you have your files)
+
pkgname=wesnoth-1.12
pkgver=1.12.6+dev
-pkgrel=9
+pkgrel=13
pkgdesc="Turn-based strategy game on a fantasy world (oldstable)"
-arch=('i686' 'x86_64')
+arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://www.wesnoth.org"
license=('GPL')
depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'sdl_net' 'boost-libs' 'bzip2' 'zlib' 'libvorbis' 'pango' 'cairo' 'fontconfig' 'dbus' 'fribidi')
@@ -19,34 +21,23 @@ makedepends=('boost' 'scons' 'git')
# package names on Debian / Ubuntu / Mint:
# libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev libsdl-net1.2-dev libboost-filesystem-dev libboost-locale-dev libboost-iostreams-dev libboost-regex-dev libboost-serialization-dev libasio-dev libboost-program-options-dev libboost-system-dev zlib1g-dev libpango1.0-dev libcairo2-dev libvorbis-dev libfontconfig1-dev libdbus-1-dev libfribidi-dev gettext-base scons pkgconf gcc g++ git
options=('!emptydirs')
-source=("wesnoth-1.12.desktop"
+source=("wesnoth-1.12-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.12"
+ "wesnoth-1.12.desktop"
"wesnothd-1.12.tmpfiles.conf"
"wesnothd-1.12.service"
"wesnoth-1.12.appdata.xml")
# Not finding some files? https://aur.archlinux.org/packages/wesnoth-1.12
# Rest assured, they are optional. Things like a launcher for your convenience…
-sha256sums=('f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877'
- '4d11e481ad8610bb2ad65290d2b3d1bf2d058485deaa9016325499b113e0f89f'
- 'bbc1a80412d3e880d695cf0e818969da90c578501b455d0a6a81a45568cd8231'
- 'e5b0bd418e97d5f8cfc9392045dc749941c71e9cf805ef6f343c318022088384')
-
-PKGEXT='.pkg.tar'
-
-prepare() {
- cd "$startdir"
+# Except for the wesnoth download, which can also be retrieved with this command:
+# git clone https://github.com/wesnoth/wesnoth.git -b 1.12 --shallow-exclude=1.12.6 wesnoth-1.12-git
- # get a shallow clone of the git repo and store it outside the srcdir
- if [ ! -d "wesnoth-1.12-git" ] ; then
- git clone https://github.com/wesnoth/wesnoth -b 1.12 --shallow-exclude=1.12.6 wesnoth-1.12-git
- msg "Git checkout done (or server timeout)"
- fi
+sha256sums=('SKIP'
+ 'f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877'
+ '4d11e481ad8610bb2ad65290d2b3d1bf2d058485deaa9016325499b113e0f89f'
+ 'f8e20adabc0ecdbce23aed375ad9b28b616cebb0d261b3c6b8e576ccb61dcdae'
+ '15a5aa798923defd3debad04379f654c60bcbd59cc238c09b15c546eff954a0a')
- # Archlinux specific (hide the usage of the $startdir variable)
- if [ ! -e "$srcdir/wesnoth-1.12-git" ] ; then
- ln -s "$startdir/wesnoth-1.12-git" "$srcdir/wesnoth-1.12-git"
- fi
-}
build() {
# As this is an older version and not worked on anymore, it will someday break
@@ -63,17 +54,19 @@ build() {
# below, and edit the start command in the file wesnothd-1.12.service.
cd wesnoth-1.12-git
- scons jobs=4 \
+ scons jobs=$(nproc) \
prefix=/usr \
version_suffix=-1.12 \
docdir=share/doc/wesnoth-1.12 \
fifodir=/run/wesnothd-1.12 \
prefsdir=.local/share/wesnoth/1.12 \
- openmp=True \
+ openmp=False \
desktop_entry=False \
+ cxx0x=True \
wesnoth wesnothd
}
+
# The commands below have to be run with root privileges.
# E.g. by prefixing them with "sudo ".
package() {
@@ -113,5 +106,5 @@ package() {
install -D -m644 "$srcdir/wesnothd-1.12.service" "$pkgdir/usr/lib/systemd/system/wesnothd-1.12.service"
# All done, but it doesn't show up? Try that:
- # update-desktop-database
+ # sudo update-desktop-database
}
diff --git a/wesnoth-1.12.appdata.xml b/wesnoth-1.12.appdata.xml
index cb7900e55937..6ca6589c141e 100644
--- a/wesnoth-1.12.appdata.xml
+++ b/wesnoth-1.12.appdata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<component type="desktop">
<id>wesnoth-1.12.desktop</id>
+ <launchable type="desktop-id">wesnoth-1.12.desktop</launchable>
<metadata_license>GFDL-1.3</metadata_license>
<project_license>GPL-2.0-or-later</project_license>
<name>Battle for Wesnoth (1.12)</name>
@@ -81,7 +82,6 @@
<category>Game</category>
<category>StrategyGame</category>
</categories>
- <launchable type="desktop-id">wesnoth-1.12.desktop</launchable>
<url type="homepage">https://www.wesnoth.org</url>
<url type="faq">https://wiki.wesnoth.org/Play</url>
<url type="help">https://wiki.wesnoth.org/WesnothManual</url>
@@ -99,4 +99,13 @@
<binary>wesnoth-1.12</binary>
<binary>wesnothd-1.12</binary>
</provides>
+ <releases>
+ <release version="1.12.6" date="2016-05-18"/>
+ <release version="1.12.5" date="2015-11-06"/>
+ <release version="1.12.4" date="2015-06-26"/>
+ <release version="1.12.3" date="2015-06-12"/>
+ <release version="1.12.2" date="2015-04-09"/>
+ <release version="1.12.1" date="2015-01-23"/>
+ <release version="1.12.0" date="2014-11-15"/>
+ </releases>
</component>
diff --git a/wesnothd-1.12.service b/wesnothd-1.12.service
index dc7b0880fce4..771d3f81cf03 100644
--- a/wesnothd-1.12.service
+++ b/wesnothd-1.12.service
@@ -9,19 +9,22 @@ Conflicts=wesnothd.service wesnothd-1.0.service wesnothd-1.2.service wesnothd-1.
[Service]
# If wesnothd is started from within the game it runs under a different user.
# Deleting the pipe resets owner, group and mode.
-ExecStopPre=/bin/rm -f /run/wesnothd-1.12/socket
+ExecStartPre=/bin/rm -f /run/wesnothd-1.12/socket
-ExecStart=/usr/bin/wesnothd-1.12 -t 2 -T 5
+ExecStart=/usr/bin/wesnothd-1.12
# You can use -c to specify a same configuration file
# (and make sure wesnothd has the required access permissions).
+# Remove remaining administration pipe:
+ExecStopPost=/bin/rm -f /run/wesnothd-1.12/socket
+
SyslogIdentifier=Wesnothd-1.12
+# Apply security settings only to ExecStart, so the Pre & Post steps run as root
+PermissionsStartOnly=yes
+WorkingDirectory=/run/wesnothd-1.12
User=nobody
Group=users
-# Remove remaining administration pipe:
-ExecStopPost=/bin/rm -f /run/wesnothd-1.12/socket
-
# Additional security-related features:
PrivateTmp=yes
PrivateDevices=yes