summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
-rw-r--r--wesnoth-1.12.appdata.xml28
-rw-r--r--wesnoth-1.12.install8
-rw-r--r--wesnothd-1.12.service5
5 files changed, 52 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 830d7bef15ab..80bcde0fc0b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = wesnoth-1.12
pkgdesc = Turn-based strategy game on a fantasy world (legacy version)
pkgver = 1.12.6
- pkgrel = 9
- url = https://www.wesnoth.org/
- install = wesnoth-1.12.install
+ pkgrel = 11
+ url = https://www.wesnoth.org
arch = i686
arch = x86_64
license = GPL
@@ -26,7 +25,6 @@ pkgbase = wesnoth-1.12
depends = cairo
depends = fontconfig
depends = dbus
- depends = readline
depends = fribidi
options = !emptydirs
source = https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-1.12.6.tar.bz2
@@ -34,12 +32,12 @@ pkgbase = wesnoth-1.12
source = wesnothd-1.12.tmpfiles.conf
source = wesnothd-1.12.service
source = wesnoth-1.12.appdata.xml
- source = wesnoth-boost.patch
+ source = wesnoth-boost.patch::https://github.com/wesnoth/wesnoth/commit/789588d11e3512b3494b4aeac11b44f1c38ad86d.patch
sha256sums = a50f384cead15f68f31cfa1a311e76a12098428702cb674d3521eb169eb92e4e
sha256sums = f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877
sha256sums = 4d11e481ad8610bb2ad65290d2b3d1bf2d058485deaa9016325499b113e0f89f
- sha256sums = e7ae24484ac6028ee705ed46b3c37f23f98126575429f415d7f273ff78579dc2
- sha256sums = bb50e9fa9551a0669471921ac57c23ed0ebb4915c0445875223dd71689f9dcda
+ sha256sums = 1167ff198b639e035769b29767c104753ade870339d4608b198dfdfcfd8a1d03
+ sha256sums = d3f031c70e59ac544712c45e6fd9be7cd79f481aad38977e7a129e1bede54840
sha256sums = ccacb1049a71935392b46f919c4045b11936b232522ed2763561fbc0fb1e40b7
pkgname = wesnoth-1.12
diff --git a/PKGBUILD b/PKGBUILD
index 253cb7826951..3e37e9723a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
_suffix=-1.12
pkgname=wesnoth-1.12
pkgver=1.12.6
-pkgrel=10
+pkgrel=11
pkgdesc="Turn-based strategy game on a fantasy world (legacy version)"
arch=('i686' 'x86_64')
-url="https://www.wesnoth.org/"
+url="https://www.wesnoth.org"
license=('GPL')
-depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'sdl_net' 'boost-libs' 'bzip2' 'zlib' 'libvorbis' 'pango' 'cairo' 'fontconfig' 'dbus' 'readline' 'fribidi')
+depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'sdl_net' 'boost-libs' 'bzip2' 'zlib' 'libvorbis' 'pango' 'cairo' 'fontconfig' 'dbus' 'fribidi')
makedepends=('boost' 'gettext' 'cmake' 'make')
checkdepends=('desktop-file-utils' 'appstream-glib')
-install=$pkgname.install
options=('!emptydirs')
#options=('!emptydirs' '!strip') #use this when building with debugging symbols
source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2"
@@ -19,13 +18,13 @@ source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.t
"wesnothd$_suffix.tmpfiles.conf"
"wesnothd$_suffix.service"
"wesnoth$_suffix.appdata.xml"
- "wesnoth-boost.patch")
+ "wesnoth-boost.patch::https://github.com/wesnoth/wesnoth/commit/789588d11e3512b3494b4aeac11b44f1c38ad86d.patch")
sha256sums=('a50f384cead15f68f31cfa1a311e76a12098428702cb674d3521eb169eb92e4e'
'f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877'
'4d11e481ad8610bb2ad65290d2b3d1bf2d058485deaa9016325499b113e0f89f'
- 'e7ae24484ac6028ee705ed46b3c37f23f98126575429f415d7f273ff78579dc2'
- 'bb50e9fa9551a0669471921ac57c23ed0ebb4915c0445875223dd71689f9dcda'
+ '1167ff198b639e035769b29767c104753ade870339d4608b198dfdfcfd8a1d03'
+ 'd3f031c70e59ac544712c45e6fd9be7cd79f481aad38977e7a129e1bede54840'
'ccacb1049a71935392b46f919c4045b11936b232522ed2763561fbc0fb1e40b7')
PKGEXT='.pkg.tar'
@@ -42,21 +41,27 @@ prepare() {
build() {
cd "$srcdir/wesnoth-$pkgver"
- mkdir build && cd build
+ # As this is an older version and not worked on anymore, it will someday break
+ # If you happen to find a fix, please fill a Pull Request for the 1.12 branch
+ # at bugs.wesnoth.org
+
+ # silence compiler warnings - they are not going to be fixed
+ export CFLAGS="$CFLAGS -w"
+ export CXXFLAGS="$CXXFLAGS -w"
+
+ rm -rf build && mkdir build && cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBINARY_SUFFIX=-1.12 \
-DDATADIRNAME=wesnoth-1.12 \
- -DFIFO_DIR=/run/wesnoth-1.12 \
- -DMANDIR=/usr/share/man/wesnoth-1.12 \
- -DDOCDIR=/usr/share/doc/wesnoth-1.12 \
+ -DDOCDIR=share/doc/wesnoth-1.12 \
+ -DFIFO_DIR=/run/wesnothd-1.12 \
-DPREFERENCES_DIR=.local/share/wesnoth/1.12 \
-DENABLE_OMP=ON \
-DENABLE_DESKTOP_ENTRY=OFF \
- -DENABLE_CAMPAIGN_SERVER=OFF \
- -DENABLE_DISPLAY_REVISION=OFF
+ -DENABLE_DISPLAY_REVISION=NO \
+ -Wno-dev # silence cmake warnings
make
- # -DLOCALEDIR=/usr/share/locale
}
check() {
@@ -72,14 +77,19 @@ package() {
cd "$srcdir/wesnoth-$pkgver"
- # better use the tools from wesnoth 1.14
+ # better use the tools from a recent version of wesnoth
rm -r "$pkgdir/usr/share/wesnoth$_suffix/data/tools"
- # these translation files are not needed anymore after building
+ # these translation files are not needed
find "$pkgdir/usr/share/wesnoth$_suffix/translations" -name wesnoth-manpages.mo -delete
find "$pkgdir/usr/share/wesnoth$_suffix/translations" -name wesnoth-manual.mo -delete
- #find "$pkgdir/usr/share/locale" -name wesnoth-manpages.mo -delete
- #find "$pkgdir/usr/share/locale" -name wesnoth-manual.mo -delete
+
+ # add suffix to manpages
+ cd "$pkgdir/usr/share/man"
+ for filename in man6/*.6 */man6/*.6
+ do
+ mv "$filename" $(dirname $filename)/$(basename $filename .6)-1.12.6
+ done
# INSTALLING of menu entry and icons as well as systemd files and appstream information:
install -D -m644 "$srcdir/wesnoth$_suffix.desktop" "$pkgdir/usr/share/applications/wesnoth$_suffix.desktop"
diff --git a/wesnoth-1.12.appdata.xml b/wesnoth-1.12.appdata.xml
index 6e8525f4999e..53e8c835f0b9 100644
--- a/wesnoth-1.12.appdata.xml
+++ b/wesnoth-1.12.appdata.xml
@@ -2,14 +2,14 @@
<component type="desktop">
<id>wesnoth-1.12.desktop</id>
<metadata_license>GFDL-1.3</metadata_license>
- <project_license>GPL-2.0+</project_license>
- <name>Battle for Wesnoth</name>
- <name xml:lang="de">Battle for Wesnoth</name>
- <name xml:lang="es">La batalla por Wesnoth</name>
- <name xml:lang="fr">La Bataille pour Wesnoth</name>
- <name xml:lang="hu">Harc Wesnothért</name>
- <name xml:lang="pl">Bitwa o Wesnoth</name>
- <name xml:lang="ru">Битва за Веснот</name>
+ <project_license>GPL-2.0-or-later</project_license>
+ <name>Battle for Wesnoth (1.12)</name>
+ <name xml:lang="de">Battle for Wesnoth (1.12)</name>
+ <name xml:lang="es">La batalla por Wesnoth (1.12)</name>
+ <name xml:lang="fr">La Bataille pour Wesnoth (1.12)</name>
+ <name xml:lang="hu">Harc Wesnothért (1.12)</name>
+ <name xml:lang="pl">Bitwa o Wesnoth (1.12)</name>
+ <name xml:lang="ru">Битва за Веснот (1.12)</name>
<summary>A turn-based strategy game with a high fantasy theme</summary>
<summary xml:lang="de">Ein rundenbasierendes Strategiespiel mit Fantasy-Thematik</summary>
<summary xml:lang="es">Un juego de estrategia basado en turnos con un tema de fantasía</summary>
@@ -65,11 +65,16 @@
<image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.12.0-2.jpg</image>
</screenshot>
<screenshot>
- <image type="source" width="1280" height="768"> https://www.wesnoth.org/images/sshots/wesnoth-1.12.4-2.jpg</image>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.12.4-2.jpg</image>
</screenshot>
<screenshot>
- <caption>The map editor</caption>
- <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.12.0-9.jpg</image>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.12.4-4.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.12.5-3.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1280" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.12.0-3.jpg</image>
</screenshot>
</screenshots>
<categories>
@@ -84,7 +89,6 @@
<url type="bugtracker">https://bugs.wesnoth.org</url>
<project_group>Wesnoth</project_group>
<developer_name>The Battle for Wesnoth Project</developer_name>
- <!-- <update_contact></update_contact> -->
<translation>wesnoth</translation>
<kudos>
<kudo>HiDpiIcon</kudo>
diff --git a/wesnoth-1.12.install b/wesnoth-1.12.install
deleted file mode 100644
index 7a80b8f7a059..000000000000
--- a/wesnoth-1.12.install
+++ /dev/null
@@ -1,8 +0,0 @@
-post_install() {
-cat << EOF
-Note:
-==> If you experience sound problems try setting your SDL_AUDIODRIVER environment variable to "dma"
-==> eg. export SDL_AUDIODRIVER="dma" ; wesnoth-1.12
-==> If "dma" doesn't work,other options are: dsp,alsa,artsc,esd,nas try to find the right output.
-EOF
-}
diff --git a/wesnothd-1.12.service b/wesnothd-1.12.service
index 12b34f16779e..946cf1e55574 100644
--- a/wesnothd-1.12.service
+++ b/wesnothd-1.12.service
@@ -3,7 +3,8 @@ Description=Wesnoth-1.12 Server Daemon
Documentation=https://www.wesnoth.org/wiki/ServerAdministration
Documentation=man:/usr/share/man/wesnoth-1.12/man6/wesnothd.6.gz
After=network.target
-Conflicts=wesnothd.service wesnothd-1.12.service wesnothd-git.service wesnothd-1.10.service
+# They use by default the same port
+Conflicts=wesnothd.service wesnothd-1.8.service wesnothd-1.10.service wesnothd-1.14.service wesnothd-devel.service wesnothd-git.service
[Service]
ExecStart=/usr/bin/wesnothd-1.12 -t 2 -T 5
@@ -21,7 +22,7 @@ ProtectSystem=yes
PrivateTmp=yes
PrivateDevices=yes
NoNewPrivileges=yes
-RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX
+RestrictAddressFamilies=AF_INET
RestrictRealtime=yes
MemoryDenyWriteExecute=yes
SystemCallArchitectures=native