summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..802ae7fd95c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = weston
+ pkgdesc = Reference implementation of a Wayland compositor
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = http://wayland.freedesktop.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = wayland-protocols
+ depends = wayland
+ depends = libxkbcommon
+ depends = libinput
+ depends = libunwind
+ depends = poppler-glib
+ depends = mtdev
+ depends = libxcursor
+ depends = glu
+ depends = pango
+ depends = colord
+ source = http://wayland.freedesktop.org/releases/weston-1.10.0.tar.xz
+ sha1sums = c9c2c8e2e798b25e7bf6b31bf0c4ef08724a7ebb
+
+pkgname = weston
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cb8d1c6c3e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 162349 2016-02-18 12:04:33Z seblu $
+# Maintainer: Sébastien Luttringer
+# Contributor: Joel Teichroeb <joel@teichroeb.net>
+
+pkgname=weston
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='Reference implementation of a Wayland compositor'
+arch=('i686' 'x86_64')
+url='http://wayland.freedesktop.org'
+license=('MIT')
+depends=('wayland' 'libxkbcommon' 'libinput' 'libunwind' 'poppler-glib' 'mtdev' 'libxcursor' 'glu' 'pango' 'colord')
+makedepends=('wayland-protocols')
+source=("http://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz")
+sha1sums=('c9c2c8e2e798b25e7bf6b31bf0c4ef08724a7ebb')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/weston \
+ --enable-libinput-backend \
+ --enable-demo-clients-install
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ # license
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}