aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO50
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
-rw-r--r--README.md7
-rw-r--r--whatever.install19
5 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..830ea12de1e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = whatever
+ pkgdesc = An unofficial Evernote client for Linux desktop
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/CellarD0-0r/whatever#readme
+ install = whatever.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = atk
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = electron
+ depends = expat
+ depends = fontconfig
+ depends = freetype2
+ depends = gcc-libs
+ depends = gconf
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libcups
+ depends = libnotify
+ depends = libx11
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
+ options = !strip
+ options = !emptydirs
+ source_i686 = https://github.com/CellarD0-0r/whatever/releases/download/v1.0.0/Whatever_1.0.0_i386.deb
+ sha512sums_i686 = 39663de9cbd3103c94991d4ffc802fcea15e67d52a925f235b18ce56aff00f436483d3255fe14310a8eebcdae3898c6d51f23e67d0749ade5a808e284cb132a7
+ source_x86_64 = https://github.com/CellarD0-0r/whatever/releases/download/v1.0.0/Whatever_1.0.0_amd64.deb
+ sha512sums_x86_64 = 426db18e2758a66d43db1b4796de8ca7a3bbbf4f674b6ddbdd089ad6ed1d2ec1689d519c82dab2d183c2ff336c9f0a6e26b97ddbd39fd4cc9259f5af0305cf12
+
+pkgname = whatever
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ac9b35cd4884
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Alexandre DERNIAME
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea1fff4ab598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: kiralex <kiralex1995 at gmail dot com>
+# Contributor: kiralex <kiralex1995 at gmail dot com>
+pkgname=whatever
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="An unofficial Evernote client for Linux desktop"
+arch=('i686' 'x86_64')
+url="https://github.com/CellarD0-0r/whatever#readme"
+license=('MIT')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'dbus' 'desktop-file-utils' 'electron' 'expat' 'fontconfig' 'freetype2' 'gcc-libs' 'gconf' 'gdk-pixbuf2' 'glib2' 'gtk2' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libcups' 'libnotify' 'libx11' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'pango')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_i686=("https://github.com/CellarD0-0r/whatever/releases/download/v1.0.0/Whatever_1.0.0_i386.deb")
+source_x86_64=("https://github.com/CellarD0-0r/whatever/releases/download/v1.0.0/Whatever_1.0.0_amd64.deb")
+sha512sums_i686=('39663de9cbd3103c94991d4ffc802fcea15e67d52a925f235b18ce56aff00f436483d3255fe14310a8eebcdae3898c6d51f23e67d0749ade5a808e284cb132a7')
+sha512sums_x86_64=('426db18e2758a66d43db1b4796de8ca7a3bbbf4f674b6ddbdd089ad6ed1d2ec1689d519c82dab2d183c2ff336c9f0a6e26b97ddbd39fd4cc9259f5af0305cf12')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 "${pkgdir}/opt/Whatever/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..19257de3758c
--- /dev/null
+++ b/README.md
@@ -0,0 +1,7 @@
+# Whatever-AUR
+PKGBUILD for Whatever
+
+# Note
+The app was made by CellarD0-0r (see [Whatever repo](https://github.com/CellarD0-0r/whatever)).
+
+This software is 100% free, non-commercial, independent and unofficial. It is not supported by Evernote© Corporation or any other commercial organization.
diff --git a/whatever.install b/whatever.install
new file mode 100644
index 000000000000..f8d56ea8b2e3
--- /dev/null
+++ b/whatever.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Whatever/whatever' '/usr/bin/whatever'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/whatever'
+ update-desktop-database -q
+}