summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8efa5505b465..9817b47e2158 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = widelands-maps-rttr-localver
pkgdesc = Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands.
- pkgver = r3946.826300c2
- pkgrel = 3
+ pkgver = v0.9.5.85
+ pkgrel = 2
url = http://siedler25.org/
arch = any
license = GPL2
makedepends = return-to-the-roots
depends = return-to-the-roots
optdepends = widelands: To play the maps with widelands.
- provides = widelands-maps-rttr=r3946.826300c2
+ provides = widelands-maps-rttr=v0.9.5.85
conflicts = widelands-maps-rttr
options = emptydirs
pkgname = widelands-maps-rttr-localver
-
diff --git a/PKGBUILD b/PKGBUILD
index 5bf1126ad4ed..88f33f214e91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@ pkgname="${_pkgname}-localver"
pkgdesc="Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands."
url='http://siedler25.org/'
arch=('any')
-pkgver=r3946.826300c2
-pkgrel=3
+pkgver=v0.9.5.85
+pkgrel=2
depends=('return-to-the-roots')
makedepends=('return-to-the-roots') # Needed for pkgver()
optdepends=('widelands: To play the maps with widelands.')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
+replaces=()
license=('GPL2')
options+=('emptydirs')
source=()
@@ -19,13 +20,10 @@ sha256sums=()
pkgver() {
# Set the pkgver to that of the installed return-to-the-root.
- pacman -Qi return-to-the-roots | grep -E '^Version' | head -n 1 | awk -F ':' '{print $2}' | awk -F '-' '{print $1}' | tr -d '[[:space:]]'
+ pacman -Q return-to-the-roots | awk '{print $2}' | sed 's|-.*||'
}
package() {
- install -v -m755 -d "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
- cd "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
- ln -sv "/usr/share/s25rttr/RTTR/MAPS/NEW" "Newer maps"
- ln -sv "/usr/share/s25rttr/RTTR/MAPS/OTHER" "Other maps"
- ln -sv "/usr/share/s25rttr/RTTR/MAPS/SEA" "Seafearing maps"
+ install -d -v -m755 "${pkgdir}/usr/share/widelands/maps"
+ ln -svr "${pkgdir}/usr/share/s25rttr/RTTR/MAPS" "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
}