summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6835f8e9ae4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wiiu-vc-extractor-git
+ pkgdesc = Extracts Wii U Virtual Console roms from dumps created via DDD or dumped from the SNES Mini
+ pkgver = r111.c78a740
+ pkgrel = 1
+ url = https://github.com/wheatevo/wiiu-vc-extractor
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = dotnet-runtime>=5
+ makedepends = dotnet-sdk>=5
+ depends = dotnet-runtime
+ provides = wiiu-vc-extractor
+ source = git+https://github.com/wheatevo/wiiu-vc-extractor
+ md5sums = SKIP
+
+pkgname = wiiu-vc-extractor-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..261460a9d0c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kookies <kookies@tutamail.com>
+_name=wiiu-vc-extractor
+_namecap=WiiuVcExtractor
+pkgname=$_name-git
+pkgver=r111.c78a740
+pkgrel=1
+pkgdesc="Extracts Wii U Virtual Console roms from dumps created via DDD or dumped from the SNES Mini"
+arch=(x86_64)
+url="https://github.com/wheatevo/$_name"
+license=('GPL3')
+depends=(dotnet-runtime)
+makedepends=(git 'dotnet-runtime>=5' 'dotnet-sdk>=5')
+optdepends=()
+provides=($_name)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_name"
+ dotnet publish -c Release
+ chmod 775 $_namecap/bin/Release/net5.0/publish
+}
+
+package() {
+ rm "$pkgdir/usr/bin/$_namecap" 2&>/dev/null || true
+ mkdir -p "$pkgdir/opt/$_namecap/"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp -R $_name/$_namecap/bin/Release/net5.0/publish/* "$pkgdir/opt/$_namecap/"
+ cd "$pkgdir/usr/bin/"
+ ln -s "/opt/$_namecap/wiiuvcextractor"
+}