summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD24
3 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 334cdb150c45..a88a3411d679 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-pkgbase = inverse-icon-theme-git
+pkgbase = win11-icon-theme-git
pkgdesc = A colorful Design icon theme for linux desktops
- pkgver = r39.f320885d
+ pkgver = r88.2293237
pkgrel = 1
- url = https://github.com/yeyushengfan258/Inverse-icon-theme
+ url = https://github.com/yeyushengfan258/win11-icon-theme
arch = any
license = GPL
depends = gtk-update-icon-cache
- conflicts = inverse-icon-theme
- conflicts = inverse-icon-theme-blue-git
- source = git+https://github.com/yeyushengfan258/Inverse-icon-theme.git
+ conflicts = win11-icon-theme
+ source = git+https://github.com/yeyushengfan258/win11-icon-theme.git
md5sums = SKIP
-pkgname = inverse-icon-theme-git
-
+pkgname = win11-icon-theme-git
diff --git a/.gitignore b/.gitignore
index 733a8f633937..51656aeb0e9d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
-*.tar.*
-pkg
-src
-Inverse-icon-theme/
+*
+
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index e145bce92808..374006ecccc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
-pkgname=inverse-icon-theme-git
-_pkgname=inverse-icon-theme
-_gitname=Inverse-icon-theme
-pkgver=r39.f320885d
+pkgname=win11-icon-theme-git
+_pkgname=win11-icon-theme
+_gitname=win11-icon-theme
+pkgver=r88.2293237
pkgrel=1
pkgdesc="A colorful Design icon theme for linux desktops"
arch=('any')
-url='https://github.com/yeyushengfan258/Inverse-icon-theme'
+url='https://github.com/yeyushengfan258/win11-icon-theme'
license=('GPL')
depends=('gtk-update-icon-cache')
optdepends=()
source=("git+${url}.git")
md5sums=('SKIP')
-conflicts=('inverse-icon-theme' 'inverse-icon-theme-blue-git')
+conflicts=('win11-icon-theme')
pkgver() {
- cd "${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- mkdir -p "${pkgdir}"
- cp -r * "${pkgdir}"
- cd "${pkgdir}"
- mkdir -p "${pkgdir}/usr/share/icons"
- ${_gitname}/install.sh -a -d "${pkgdir}/usr/share/icons"
- rm -rf "${pkgdir}/${_gitname}"
+ install -dm755 "${pkgdir}/usr/share/icons"
+ "${srcdir}/${_gitname}/install.sh" -a -d "${pkgdir}/usr/share/icons"
}