summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
-rw-r--r--futex.patch11
3 files changed, 9 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29e9106d93f4..749cc40cfb5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-lol
pkgdesc = A compatibility layer for running Windows programs - GloriousEggroll custom wine build for running League of Legends
- pkgver = 7.0_5
+ pkgver = 7.0_8
pkgrel = 1
epoch = 1
url = https://github.com/GloriousEggroll/wine-ge-custom
@@ -151,11 +151,9 @@ pkgbase = wine-lol
optdepends = dosbox
options = staticlibs
options = !lto
- source = wine-lol-7.0_5.tar.gz::https://github.com/GloriousEggroll/wine/archive/6703dc23fbb57a32261864bf547d16ba508351fb.tar.gz
+ source = wine-lol-7.0_8.tar.gz::https://github.com/GloriousEggroll/wine/archive/82c1eae441366b9d289f3e9e0a8ce019bd10201f.tar.gz
source = 30-win32-aliases.conf
- source = futex.patch
- sha512sums = 8ffa445333f6e677f9df78c93fa05a3634c30f11071f5367f5c36cf143410410a0d3570eb8e4fe50959293c5b9c695498d3db1ca5c27b7d91665697eb1365d23
+ sha512sums = c02eafda75cbc11bab815efc65469340eb4444918f4a4d6b516ff5053126ebae5a1f8d54cd71fb401d67c2db7ed36bbed06bf1f6d147bf4c4aff6dd2a0901fd3
sha512sums = 6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb
- sha512sums = 02c650aa559a33b7f2bc35deb2946b28473428e1c166895f0e60d3ab766475db172f974e24860850d1575a843056b673fb1dfe1390204d528b1323cc65d0efce
pkgname = wine-lol
diff --git a/PKGBUILD b/PKGBUILD
index d82e2060f783..486acf284270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,18 @@
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=wine-lol
-pkgver=7.0_5
+pkgver=7.0_8
pkgrel=1
epoch=1
# Be sure to use commits from a "ge-lol-XXX" branch here
-_gitver=6703dc23fbb57a32261864bf547d16ba508351fb
+_gitver=82c1eae441366b9d289f3e9e0a8ce019bd10201f
# Using VCS source here (git+https...) takes forever so get a snapshot instead
-source=($pkgname-$pkgver.tar.gz::https://github.com/GloriousEggroll/wine/archive/$_gitver.tar.gz
- 30-win32-aliases.conf
- futex.patch)
-sha512sums=('8ffa445333f6e677f9df78c93fa05a3634c30f11071f5367f5c36cf143410410a0d3570eb8e4fe50959293c5b9c695498d3db1ca5c27b7d91665697eb1365d23'
- '6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb'
- '02c650aa559a33b7f2bc35deb2946b28473428e1c166895f0e60d3ab766475db172f974e24860850d1575a843056b673fb1dfe1390204d528b1323cc65d0efce')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/GloriousEggroll/wine/archive/$_gitver.tar.gz"
+ 30-win32-aliases.conf)
+sha512sums=('c02eafda75cbc11bab815efc65469340eb4444918f4a4d6b516ff5053126ebae5a1f8d54cd71fb401d67c2db7ed36bbed06bf1f6d147bf4c4aff6dd2a0901fd3'
+ '6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb')
pkgdesc="A compatibility layer for running Windows programs - GloriousEggroll custom wine build for running League of Legends"
url="https://github.com/GloriousEggroll/wine-ge-custom"
@@ -116,15 +114,6 @@ install=wine.install
prepare() {
# Allow ccache to work
mv wine-$_gitver $pkgname
-
- # Fix futex compilation error
- patch -d $pkgname -Np1 -i "$srcdir"/futex.patch
-
- # Fix opencl header path
- sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i $pkgname/configure*
-
- # Fix openldap 2.5+ detection
- sed 's/-lldap_r/-lldap/' -i $pkgname/configure
}
build() {
diff --git a/futex.patch b/futex.patch
deleted file mode 100644
index b1c41eb94a0e..000000000000
--- a/futex.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --color -rupN a/dlls/ntdll/unix/fsync.c b/dlls/ntdll/unix/fsync.c
---- a/dlls/ntdll/unix/fsync.c
-+++ b/dlls/ntdll/unix/fsync.c
-@@ -51,6 +51,7 @@
-
- #include "unix_private.h"
- #include "fsync.h"
-+#include <linux/futex.h>
-
- WINE_DEFAULT_DEBUG_CHANNEL(fsync);
-