summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
-rw-r--r--wine-lol-autoconf-2.70.patch37
2 files changed, 38 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e9f034ed388..60727cba7ebd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ source=(https://dl.winehq.org/wine/source/5.x/wine-$_pkgbasever.tar.xz
"wine-staging-v$_pkgbasever.tar.gz::https://github.com/wine-staging/wine-staging/archive/v$_pkgbasever.tar.gz"
https://raw.githubusercontent.com/wine-staging/wine-staging/8d4d0a840e6ce434483edd81acb3be90fd734e44/patches/user32-rawinput-mouse/0005-server-Broadcast-rawinput-message-if-request-flag-is.patch
30-win32-aliases.conf
- $pkgname-autoconf-2.70.patch::https://github.com/wine-mirror/wine/commit/d7645b67c350f7179a1eba749ec4524c74948d86.patch
+ $pkgname-autoconf-2.70.patch
$pkgname-bug-47198-fix.patch)
sha512sums=('b12b0eff228ecd783fec8bf91f97e4387125226b172046d800e1fbffa303ceca32f1f647b9e8ceb24d303c23eb57188be14ddd8ba5fc04ba781a69186fbe6be4'
'7ddf5699834a6e04b094a7cae008175c874415d22554bac38176f3121b9533071ef610f8b5a0dd3ce3e4adf8a9d4ac214aa1cee7634959c5150b66fbb74710b7'
diff --git a/wine-lol-autoconf-2.70.patch b/wine-lol-autoconf-2.70.patch
new file mode 100644
index 000000000000..02874eb2b4c8
--- /dev/null
+++ b/wine-lol-autoconf-2.70.patch
@@ -0,0 +1,37 @@
+From d7645b67c350f7179a1eba749ec4524c74948d86 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Thu, 29 Oct 2020 22:51:57 +0000
+Subject: [PATCH] aclocal.m4: Fix compatibility with upcoming autoconf-2.70.
+
+Under autoconf 2.69c (beta) `./configure` fails as:
+
+```
+./configure
+...
+checking for msgfmt... msgfmt
+./configure: line 7441: syntax error near unexpected token `newline'
+./configure: line 7441: ` '''
+```
+
+This happens due to underquoting of a snippet
+argument for `AS_VAR_SET_IF` call.
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Signed-off-by: Alexandre Julliard <julliard@winehq.org>
+---
+ aclocal.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/aclocal.m4 b/aclocal.m4
+index c5edd85cee49..bd8ca6b33e55 100644
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -28,7 +28,7 @@ dnl Like AC_CHECK_TOOL but without the broken fallback to non-prefixed name
+ dnl
+ AC_DEFUN([WINE_CHECK_HOST_TOOL],
+ [AS_VAR_SET_IF([ac_tool_prefix],
+- AC_CHECK_PROG([$1],[${ac_tool_prefix}$2],[${ac_tool_prefix}$2],,[$4]))
++ [AC_CHECK_PROG([$1],[${ac_tool_prefix}$2],[${ac_tool_prefix}$2],,[$4])])
+ AS_VAR_IF([ac_cv_prog_$1],[],
+ [AS_VAR_IF([cross_compiling],[yes],[],
+ [AS_UNSET([ac_cv_prog_$1])