summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb56c548e36a..8800b7d9bfb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = winfile
makedepends = mingw-w64-headers
depends = mingw-w64-crt
depends = wine
- source = src::git+https://github.com/microsoft/winfile.git
+ source = srcgit::git+https://github.com/microsoft/winfile.git
source = mingw_compile.patch
source = https://patch-diff.githubusercontent.com/raw/microsoft/winfile/pull/262.patch
source = winfile
diff --git a/.gitignore b/.gitignore
index 7efc1c5f9f98..b874db1fa59b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src/
pkg/
*.zst
262.patch
+srcgit/
diff --git a/PKGBUILD b/PKGBUILD
index 137496b1c10c..eca51d1c3d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ backup=()
options=()
install=
changelog=
-source=("src::git+https://github.com/microsoft/winfile.git"
+source=("srcgit::git+https://github.com/microsoft/winfile.git"
"mingw_compile.patch"
"https://patch-diff.githubusercontent.com/raw/microsoft/winfile/pull/262.patch"
"winfile")
@@ -31,7 +31,7 @@ sha256sums=('SKIP'
validpgpkeys=()
prepare() {
- cd "$srcdir/src"
+ cd "$srcdir/srcgit"
git checkout v$pkgver
# Fix some issues compiling on *nix (e.g. directory separator, toolchain location, header names, etc)
git apply ../mingw_compile.patch
@@ -40,12 +40,12 @@ prepare() {
}
build() {
- cd "$srcdir/src"
+ cd "$srcdir/srcgit"
TOOLCHAIN=x86_64-w64-mingw32- make
}
package() {
- cd "$srcdir/src"
+ cd "$srcdir/srcgit"
mkdir -p "$pkgdir"/usr/share/$pkgname
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
mkdir -p "$pkgdir"/usr/bin