summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19758c417d88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wlchewing-git
+ pkgdesc = Wayland Chinese zhuyin input method with libchewing
+ pkgver = v0.2.1.r0.2a02c6b
+ pkgrel = 1
+ url = https://github.com/xdavidwu/wlchewing
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ makedepends = wayland-protocols
+ depends = wayland
+ depends = cairo
+ depends = pango
+ depends = libchewing
+ depends = libxkbcommon
+ depends = systemd-libs
+ provides = wlchewing
+ conflicts = wlchewing
+ source = git+https://github.com/xdavidwu/wlchewing.git
+ sha256sums = SKIP
+
+pkgname = wlchewing-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8f006315b2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Pochang Chen <johnchen902@gmail.com>
+pkgname=wlchewing-git
+pkgver=v0.2.1.r0.2a02c6b
+pkgrel=1
+pkgdesc="Wayland Chinese zhuyin input method with libchewing "
+arch=('x86_64')
+url="https://github.com/xdavidwu/wlchewing"
+license=('MIT')
+depends=('wayland' 'cairo' 'pango' 'libchewing' 'libxkbcommon' 'systemd-libs')
+makedepends=('meson' 'git' 'wayland-protocols')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/xdavidwu/wlchewing.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ arch-meson . build
+ meson compile -C build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ meson install -C build --destdir "$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}