summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3a575eaac67..7e61d836e5d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,13 @@ pkgbase = wljoywake
pkgrel = 1
url = https://github.com/nowrep/wljoywake
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = meson
makedepends = wayland-protocols
depends = wayland
- source = https://github.com/nowrep/wljoywake/archive/refs/tags/v0.3.tar.gz
+ depends = systemd-libs
+ depends = glibc
+ source = wljoywake-0.3.tar.gz::https://github.com/nowrep/wljoywake/archive/refs/tags/v0.3.tar.gz
b2sums = 3086de8b5e2d25dea9fc01e88297d4f4e67c14bd4b914e721cf3435197e6893a171d89acc8e4a90457b3100b968a8dc11f992d49bda2f17375a3049d39999529
pkgname = wljoywake
diff --git a/PKGBUILD b/PKGBUILD
index 24e493bfec02..ed6fd20cd644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@ pkgver=0.3
pkgrel=1
pkgdesc='Wayland idle inhibit on joystick input'
arch=(x86_64)
-url=https://github.com/nowrep/wljoywake
-license=(GPL2)
-depends=(wayland)
+url='https://github.com/nowrep/wljoywake'
+license=(GPL-2.0-only)
+depends=(wayland systemd-libs glibc)
makedepends=(meson wayland-protocols)
-source=("https://github.com/nowrep/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
b2sums=('3086de8b5e2d25dea9fc01e88297d4f4e67c14bd4b914e721cf3435197e6893a171d89acc8e4a90457b3100b968a8dc11f992d49bda2f17375a3049d39999529')
build() {
@@ -22,7 +22,7 @@ check() {
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}
-# vim: set ts=4 sw=4 tw=0 et :
+# vim:set ts=2 sw=2 et: