summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rw-r--r--fix_12_year_display.patch24
-rw-r--r--manpage_fixes.patch19
-rw-r--r--manpage_xpm_notes.patch30
5 files changed, 20 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a8c26f85382..1c4cc6cc31f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,15 @@
pkgbase = wmclock
pkgdesc = Dockable clock applet for Window Maker
- pkgver = 1.0.14
+ pkgver = 1.0.16
pkgrel = 1
- url = http://www.bluestop.org/wmclock/
+ url = http://www.dockapps.net/wmclock/
arch = i686
arch = x86_64
license = GPL
- makedepends = imake
depends = libxpm
optdepends = windowmaker
- source = http://www.bluestop.org/wmclock/wmclock-1.0.14.tar.gz
- source = fix_12_year_display.patch
- source = manpage_fixes.patch
- source = manpage_xpm_notes.patch
- md5sums = 15a83f45e2baabec26b22a2153aa2417
- md5sums = 3063f4dd017b24046ba9d0c932d85583
- md5sums = cff551b14bab22daad6f546602ddb90a
- md5sums = 7e716bc8b110a41e548f7bbaf707b2b9
+ source = https://www.dockapps.net/download/wmclock-1.0.16.tar.gz
+ sha256sums = 3f8bb5df3160d5919d19cf26d45449e6e1260d2a2f485e61f35e64a49639a2d3
pkgname = wmclock
diff --git a/PKGBUILD b/PKGBUILD
index 2c9930e09584..877dc8946f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,31 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
pkgname=wmclock
-pkgver=1.0.14
+pkgver=1.0.16
pkgrel=1
pkgdesc="Dockable clock applet for Window Maker"
arch=('i686' 'x86_64')
-url="http://www.bluestop.org/wmclock/"
+url="http://www.dockapps.net/wmclock/"
license=("GPL")
depends=('libxpm')
optdepends=('windowmaker')
-makedepends=('imake')
-source=("http://www.bluestop.org/wmclock/${pkgname}-${pkgver}.tar.gz"
- "fix_12_year_display.patch"
- "manpage_fixes.patch"
- "manpage_xpm_notes.patch")
-md5sums=('15a83f45e2baabec26b22a2153aa2417'
- '3063f4dd017b24046ba9d0c932d85583'
- 'cff551b14bab22daad6f546602ddb90a'
- '7e716bc8b110a41e548f7bbaf707b2b9')
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+source=("https://www.dockapps.net/download/$pkgname-$pkgver.tar.gz")
+sha256sums=('3f8bb5df3160d5919d19cf26d45449e6e1260d2a2f485e61f35e64a49639a2d3')
- for patch in ${srcdir}/*.patch ; do
- patch -Np1 -i "${patch}"
- done
+prepare() {
+ cd dockapps-*
+ autoreconf -fiv
+}
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --sharedir=/usr/share
- make
+build() {
+ cd dockapps-*
+ ./configure --prefix=/usr
+ make V=0
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
- make DESTDIR=${pkgdir} install.man
- make DESTDIR=${pkgdir}/usr install.share
- install -Dm644 README ${pkgdir}/usr/share/doc/wmclock/README
+ cd dockapps-*
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README "${pkgdir}"/usr/share/doc/wmclock/README
}
diff --git a/fix_12_year_display.patch b/fix_12_year_display.patch
deleted file mode 100644
index 27609410b157..000000000000
--- a/fix_12_year_display.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Description: Fix display when both -12 and -year are given
-Author: Vino Fernando Crescini <jcrescin@cit.uws.edu.au>
-Bug-Debian: http://bugs.debian.org/228985
-
-Index: wmclock-1.0.14/wmclock.c
-===================================================================
---- wmclock-1.0.14.orig/wmclock.c 2010-12-22 13:12:28.000000000 +0100
-+++ wmclock-1.0.14/wmclock.c 2011-06-02 12:11:51.233840631 +0200
-@@ -849,7 +849,14 @@
- #endif /* !ONLY_SHAPED_WINDOW */
- for (i = 0; i < NUM_TIME_POSITIONS; i++)
- {
-- xPos[i] += enable12HourClock ? timePos24[i] : timePos12[i];
-+ if (enable12HourClock && (!enableYearDisplay))
-+ {
-+ xPos[i] += timePos24[i];
-+ }
-+ else
-+ {
-+ xPos[i] += timePos12[i];
-+ }
- }
-
- /* Open the display */
diff --git a/manpage_fixes.patch b/manpage_fixes.patch
deleted file mode 100644
index 38fbf46e83a6..000000000000
--- a/manpage_fixes.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Description: Manpage fixes
- Fix first line and use proper escape sequence for (c) character.
-Author: Sandro Tosi <matrixhasu@gmail.com>
-
-Index: wmclock-1.0.14/wmclock.man.in
-===================================================================
---- wmclock-1.0.14.orig/wmclock.man.in 2010-12-22 13:12:19.000000000 +0100
-+++ wmclock-1.0.14/wmclock.man.in 2011-06-02 12:11:40.157887000 +0200
-@@ -24,9 +24,7 @@
- .TH wmclock 1x "@DATE@" "Version @VERSION@"
- .\" ----------------------------------------------------------------
- .SH NAME
--.PP
--.BR wmclock :
--a dockable clock for the Window Maker window manager
-+wmclock \- A dockable clock for the Window Maker window manager
- .\" ----------------------------------------------------------------
- .SH SYNOPSIS
- .HP
diff --git a/manpage_xpm_notes.patch b/manpage_xpm_notes.patch
deleted file mode 100644
index 5662d7ece98c..000000000000
--- a/manpage_xpm_notes.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Description: Document Debian-specific XPM files location
- Add a section about usage of translated XPM files in Debian.
-Author: Sandro Tosi <matrixhasu@gmail.com>
-
-Index: wmclock-1.0.14/wmclock.man.in
-===================================================================
---- wmclock-1.0.14.orig/wmclock.man.in 2011-06-02 12:11:40.157887000 +0200
-+++ wmclock-1.0.14/wmclock.man.in 2011-06-02 12:11:45.337865330 +0200
-@@ -160,6 +160,21 @@
- the bottom. The weekday abbreviations must also be arranged
- vertically, beginning with Monday at the top and continuing to Sunday
- at the bottom.
-+.PP
-+On Debian systems you can find XPM files for a variety of languages in:
-+.PP
-+.RS
-+.BR /usr/share/wmclock/
-+.RE
-+.PP
-+For example, to have a French display, you could use the following
-+command line:
-+.PP
-+.RS
-+.TQ
-+wmclock \-monthxpm /usr/share/wmclock/lang.french/month.xpm \-weekdayxpm /usr/share/wmclock/lang.french/weekday.xpm
-+.RE
-+.PP
- .SS Obsolete Options
- .PP
- In order to maintain command-line compatibility (mostly) with