summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--makefile.patch17
-rw-r--r--wmcpu-1.4.tar.gzbin0 -> 6712 bytes
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e41b910cba29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wmcpu
+ pkgdesc = Dockapp CPU monitor resembling Xosview.
+ pkgver = 1.4
+ pkgrel = 3
+ url = http://www.ne.jp/asahi/linux/timecop/#wmcpu
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ depends = x-server
+ source = wmcpu-1.4.tar.gz
+ source = makefile.patch
+ md5sums = e690eda219cdf285476bcbb602a117ff
+ md5sums = 5e80a4fc615e6ffbce9ae36df698b88d
+
+pkgname = wmcpu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a734c618287
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: osa_k <osak.63@gmail.com>
+# Contributor: Brian F. G. Bidulock <bidulock@openss7.org>
+
+pkgname=wmcpu
+pkgver=1.4
+pkgrel=3
+pkgdesc="Dockapp CPU monitor resembling Xosview."
+arch=('i686' 'x86_64')
+url="http://www.ne.jp/asahi/linux/timecop/#wmcpu"
+license=("GPL")
+depends=('x-server')
+makedepends=('make')
+#source=(http://dockapps.windowmaker.org/download.php/id/673/wmcpu-1.4.tar.gz
+# makefile.patch)
+source=(wmcpu-1.4.tar.gz
+ makefile.patch)
+md5sums=('e690eda219cdf285476bcbb602a117ff'
+ '5e80a4fc615e6ffbce9ae36df698b88d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/makefile.patch"
+ make || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -m755 -d "${pkgdir}/usr/bin"
+ make DESTDIR=${pkgdir} install
+}
+
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..b132b948d533
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.old 2005-12-23 01:40:10.000000000 +0900
++++ Makefile 2011-09-15 02:03:58.000000000 +0900
+@@ -2,12 +2,12 @@
+ CFLAGS = -O3 -Wall
+ #DEBUG FLAGS HERE:
+ #CFLAGS += -g -ggdb
+-LDFLAGS = -L/usr/X11R6/lib -lXpm -lXext -lX11
++LDFLAGS = -lXpm -lXext -lX11
+ OBJS = wmcpu.o
+
+ # where to install this program (also for packaging stuff)
+ DESTDIR =
+-PREFIX = $(DESTDIR)/usr/X11R6
++PREFIX = $(DESTDIR)/usr
+ INSTALL = -m 755
+
+ .PHONY: all clean
diff --git a/wmcpu-1.4.tar.gz b/wmcpu-1.4.tar.gz
new file mode 100644
index 000000000000..ce2b170c05ce
--- /dev/null
+++ b/wmcpu-1.4.tar.gz
Binary files differ