summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7de161f8c9fc..af1405b31e44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = wolfssl
pkgdesc = small, fast, portable implementation of TLS/SSL for embedded devices to the cloud (formerly CyaSSL)
- pkgver = 4.3.0
+ pkgver = 4.4.0
pkgrel = 1
url = https://www.wolfssl.com/
arch = i686
arch = x86_64
license = GPL
depends = sh
- source = wolfssl-4.3.0-stable.tar.gz::https://github.com/wolfSSL/wolfssl/archive/v4.3.0-stable.tar.gz
- source = https://github.com/wolfSSL/wolfssl/releases/download/v4.3.0-stable/wolfssl-4.3.0-stable.tar.gz.asc
+ source = wolfssl-4.4.0-stable.tar.gz::https://github.com/wolfSSL/wolfssl/archive/v4.4.0-stable.tar.gz
+ source = https://github.com/wolfSSL/wolfssl/releases/download/v4.4.0-stable/wolfssl-4.4.0-stable.tar.gz.asc
validpgpkeys = EBC80E415CA29677
- sha256sums = 6896f8ad6c44aff3e583006eeee839600848a0e37118ebbb7514eca9409ae08b
+ sha256sums = 7f854804c8ae0ca49cc77809e38e9a3b5a8c91ba7855ea928e6d6651b0d35f18
sha256sums = SKIP
pkgname = wolfssl
diff --git a/PKGBUILD b/PKGBUILD
index 03591895b7f5..8374f4666870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maxime Vincent <maxime.vince@gmail.com>
pkgname=wolfssl
-pkgver=4.3.0
+pkgver=4.4.0
pkgrel=1
pkgdesc='small, fast, portable implementation of TLS/SSL for embedded devices to the cloud (formerly CyaSSL)'
arch=(i686 x86_64)
@@ -11,7 +11,7 @@ depends=('sh')
url='https://www.wolfssl.com/'
source=(${pkgname}-${pkgver}-stable.tar.gz::https://github.com/wolfSSL/wolfssl/archive/v$pkgver-stable.tar.gz
https://github.com/wolfSSL/wolfssl/releases/download/v${pkgver}-stable/${pkgname}-${pkgver}-stable.tar.gz.asc)
-sha256sums=('6896f8ad6c44aff3e583006eeee839600848a0e37118ebbb7514eca9409ae08b'
+sha256sums=('7f854804c8ae0ca49cc77809e38e9a3b5a8c91ba7855ea928e6d6651b0d35f18'
'SKIP')
validpgpkeys=('EBC80E415CA29677')
@@ -20,10 +20,15 @@ build() {
cd $pkgname-$pkgver-stable
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --disable-fastmath \
- --disable-fasthugemath --disable-bump \
- --enable-opensslextra --enable-fortress \
- --enable-keygen --enable-certgen \
- --disable-debug --disable-ntru --disable-examples --enable-distro
+ --disable-bump \
+ --enable-opensslextra \
+ --enable-fortress \
+ --enable-keygen \
+ --enable-certgen \
+ --disable-debug \
+ --disable-ntru \
+ --disable-examples \
+ --enable-distro
make
}