summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96e4b4d6622d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = worddle-git
+ pkgdesc = Wordle is a web-based word game developed by Josh Wardle. This wrapper written in Qt removes all bloat by NYT from the game.
+ pkgver = 1.0.r38.3826592
+ pkgrel = 1
+ url = https://github.com/keshavbhatt/worddle
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = qt5-base
+ depends = qt5-base
+ depends = qt5-webengine
+ provides = worddle
+ conflicts = worddle
+ source = worddle::git+https://github.com/keshavbhatt/worddle
+ sha256sums = SKIP
+
+pkgname = worddle-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ad7d31d7fce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: keshavnrj
+
+pkgname=worddle-git
+pkgver=1.0.r38.3826592
+pkgrel=1
+pkgdesc="Wordle is a web-based word game developed by Josh Wardle. This wrapper written in Qt removes all bloat by NYT from the game."
+arch=('armv6h' 'armv7h' 'arm' 'aarch64' 'i686' 'x86_64')
+url="https://github.com/keshavbhatt/worddle"
+license=('MIT')
+depends=('qt5-base' 'qt5-webengine')
+makedepends=('git' 'qt5-base')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("${pkgname%-git}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+
+ printf "%s.r%s.%s" "$(git describe --tags --abbrev=0)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ qmake src
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make INSTALL_ROOT="${pkgdir}" install
+}