summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5951707bc93d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wordlist-git
+ pkgdesc = Generates all possible permutations of a given charset.
+ pkgver = r90.6ec5142
+ pkgrel = 1
+ url = https://github.com/rexos/wordlist
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = bash
+ depends = python
+ provides = wordlist-git
+ conflicts = wordlist-git
+ source = wordlist-git::git+https://github.com/rexos/wordlist.git
+ md5sums = SKIP
+
+pkgname = wordlist-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06f268caa2ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sebastian Neef <aur AT gehaxelt DOT IN>
+pkgbase=wordlist-git
+pkgname=wordlist-git
+pkgver=r90.6ec5142
+pkgrel=1
+pkgdesc="Generates all possible permutations of a given charset."
+arch=('any')
+url="https://github.com/rexos/wordlist"
+license=('GPL3')
+depends=('python')
+makedepends=('git' 'bash')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("$pkgname::git+https://github.com/rexos/wordlist.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}