summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xwrapaur6
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e17aad71d2cd..28fc30b222ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Feb 4 05:11:23 UTC 2016
+# Thu Mar 24 04:53:29 UTC 2016
pkgbase = wrapaur
pkgdesc = A simple pacman and AUR wrapper written in bash to help with everyday package tasks
- pkgver = 2.0.9
- pkgrel = 3
+ pkgver = 2.0.10
+ pkgrel = 1
url = https://aur.archlinux.org/packages/wrapaur/
arch = i686
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = wrapaur
depends = sudo
optdepends = s-nail: required for mail notifications
source = wrapaur
- md5sums = c78df0bfef4836aa354b07c480fbbc60
+ md5sums = 50e7d9bee3af49f0ebf7ec9f63dee237
pkgname = wrapaur
diff --git a/PKGBUILD b/PKGBUILD
index 3791e473257a..a0325861c60c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: William Hahn <bill@hahn3.com>
pkgname=wrapaur
-pkgver=2.0.9
-pkgrel=3
+pkgver=2.0.10
+pkgrel=1
pkgdesc="A simple pacman and AUR wrapper written in bash to help with everyday package tasks"
arch=('i686' 'x86_64')
url="https://aur.archlinux.org/packages/wrapaur/"
@@ -10,7 +10,7 @@ license=('GPL')
depends=('bash' 'coreutils' 'curl' 'grep' 'gawk' 'sed' 'git' 'pacman' 'sudo')
optdepends=('s-nail: required for mail notifications')
source=("wrapaur")
-md5sums=('c78df0bfef4836aa354b07c480fbbc60')
+md5sums=('50e7d9bee3af49f0ebf7ec9f63dee237')
package() {
install -Dm755 wrapaur "$pkgdir/usr/bin/wrapaur"
diff --git a/wrapaur b/wrapaur
index 174320f129c3..34289c36642b 100755
--- a/wrapaur
+++ b/wrapaur
@@ -558,10 +558,10 @@ check_all_depends()
line=$(echo "$line" | sed -e "s/>=[^=]*$//g" -e "s/<=[^=]*$//g" -e "s/<[^<]*$//g" -e "s/>[^>]*$//g")
pacman -Qi $line &>/dev/null
if [[ $? == 1 ]]; then
- sudo pacman -S --needed $line
+ sudo pacman -S --needed --asdeps $line
if [[ $? == 1 ]]; then
check_all_depends $line
- aur_git_install $line
+ aur_git_install $line --asdeps
fi
fi
done
@@ -606,7 +606,7 @@ aur_git_install()
if [ "$echoice" == "y" ] || [ "$echoice" == "Y" ] || [[ -z $echoice ]]; then
$EDITOR PKGBUILD
fi
- makepkg -si
+ makepkg -si $2
cd $HOME/.wrapaur
raprompt=$(echo -e "${color1}:: ${color2}Remove source folder? [Y/n] ${color3}")
rachoice=z