summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0001-install-headers.patch19
-rw-r--r--PKGBUILD13
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65253f3fac8d..7e8d73fefc42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,13 @@ pkgbase = wsa-git
makedepends = git
makedepends = cmake
makedepends = ninja
+ depends = wayland
provides = wsa
conflicts = wsa
- source = wsa::git+https://github.com/GPUOpen-Drivers/wsa.git
+ source = wsa::git+https://github.com/GPUOpen-Drivers/wsa.git#branch=master
+ source = 0001-install-headers.patch
sha256sums = SKIP
+ sha256sums = df079c020c45534e4015753e319f28345e269821b1abf2a3fea55627252dcd78
pkgname = wsa-git
diff --git a/0001-install-headers.patch b/0001-install-headers.patch
new file mode 100644
index 000000000000..7e2f4879f04a
--- /dev/null
+++ b/0001-install-headers.patch
@@ -0,0 +1,19 @@
+diff --git a/wayland/CMakeLists.txt b/wayland/CMakeLists.txt
+index 531b67e..8053174 100755
+--- a/wayland/CMakeLists.txt
++++ b/wayland/CMakeLists.txt
+@@ -42,9 +42,12 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-error=deprecated-declarations -Wno-depr
+ set(SOURCES src/wsa_wayland.c)
+
+ add_library(amdgpu_wsa_wayland SHARED ${SOURCES})
++set_target_properties(amdgpu_wsa_wayland PROPERTIES PUBLIC_HEADER "../inc/wsa.h")
+
+ target_include_directories ( amdgpu_wsa_wayland PUBLIC ${WAYLAND_INCLUDE_DIRS} )
+ target_link_libraries ( amdgpu_wsa_wayland PUBLIC ${WAYLAND_LDFLAGS} )
+
+-install(TARGETS amdgpu_wsa_wayland DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-
++install(TARGETS amdgpu_wsa_wayland
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++)
diff --git a/PKGBUILD b/PKGBUILD
index c8005659b10b..6b624cdfc64b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ arch=('x86_64')
url="https://github.com/GPUOpen-Drivers/wsa"
license=('custom')
groups=()
-depends=()
+depends=('wayland')
makedepends=('git' 'cmake' 'ninja') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -23,9 +23,11 @@ replaces=()
backup=()
options=()
install=
-source=('wsa::git+https://github.com/GPUOpen-Drivers/wsa.git')
+source=('wsa::git+https://github.com/GPUOpen-Drivers/wsa.git#branch=master'
+ '0001-install-headers.patch')
noextract=()
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ 'df079c020c45534e4015753e319f28345e269821b1abf2a3fea55627252dcd78')
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
@@ -36,6 +38,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/wsa"
+ patch -p1 < ../../0001-install-headers.patch
+}
+
build() {
cd "$srcdir/wsa"
cmake \