summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--CHANGELOG5
-rw-r--r--PKGBUILD7
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f09529407c6f..15af6341db5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wtwitch
pkgdesc = Terminal user interface for Twitch
- pkgver = 2.3.4
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/krathalan/wtwitch
changelog = CHANGELOG
@@ -10,12 +10,13 @@ pkgbase = wtwitch
depends = curl
depends = jq
depends = streamlink
+ optdepends = fzf: for browsing and watching streams with fzf
optdepends = mpv: for watching streams
optdepends = vlc: for watching streams
- source = https://github.com/krathalan/wtwitch/archive/refs/tags/2.3.4.tar.gz
- source = https://github.com/krathalan/wtwitch/releases/download/2.3.4/2.3.4.tar.gz.sig
+ source = https://github.com/krathalan/wtwitch/archive/refs/tags/2.4.0.tar.gz
+ source = https://github.com/krathalan/wtwitch/releases/download/2.4.0/2.4.0.tar.gz.sig
validpgpkeys = 0C6B73F391FA26F0EBCD1F75C0F9AEE56E47D174
- sha256sums = fb6b55d0538ec954a1c1fcff1b404fc1f9a5539319a07a879d0dcbc60073acea
- sha256sums = c1434ecf5ce797d88163769e990eac5bccebca6e332ef4b5e440d3e1d8796bc3
+ sha256sums = 3316677ee78f1f9fbb389d14f7106c9c355731390f13dae8816e4be131b996ff
+ sha256sums = 56d52917c2dc0370304b87a4c8c0edb23b513c626cee77f99b51493f046c8424
pkgname = wtwitch
diff --git a/CHANGELOG b/CHANGELOG
index 0ff466c2db2a..7ee3093f83db 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,5 +1,6 @@
See the full changelog for all versions at:
https://github.com/krathalan/wtwitch/blob/master/FULLCHANGELOG
-2.3.4 (November 30, 2021)
- Fixed an issue where users would be prompted to show more streamers infinitely even if there were no more streamers for that game
+2.4.0 (May 15, 2022)
+ Added command to show and watch subscribed online streamers via fzf from yazgoo (PR#7)
+ wtwitch o
diff --git a/PKGBUILD b/PKGBUILD
index 187300b95941..1bfa20696c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# General package information
pkgname=wtwitch
-pkgver=2.3.4
+pkgver=2.4.0
pkgrel=1
pkgdesc="Terminal user interface for Twitch"
url="https://github.com/krathalan/wtwitch"
@@ -13,13 +13,14 @@ changelog="CHANGELOG"
# Dependencies
depends=("curl" "jq" "streamlink")
makedepends=("scdoc")
-optdepends=('mpv: for watching streams'
+optdepends=('fzf: for browsing and watching streams with fzf'
+ 'mpv: for watching streams'
'vlc: for watching streams')
# Download information
source=("${url}/archive/refs/tags/${pkgver}.tar.gz" "${url}/releases/download/${pkgver}/${pkgver}.tar.gz.sig")
validpgpkeys=("0C6B73F391FA26F0EBCD1F75C0F9AEE56E47D174")
-sha256sums=("fb6b55d0538ec954a1c1fcff1b404fc1f9a5539319a07a879d0dcbc60073acea" "c1434ecf5ce797d88163769e990eac5bccebca6e332ef4b5e440d3e1d8796bc3")
+sha256sums=("3316677ee78f1f9fbb389d14f7106c9c355731390f13dae8816e4be131b996ff" "56d52917c2dc0370304b87a4c8c0edb23b513c626cee77f99b51493f046c8424")
build() {
cd "${srcdir}/${pkgname}-${pkgver}/src"