summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch13
3 files changed, 22 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3cf05758064..59f641d7c7ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxparaver
pkgdesc = Expressive powerful and flexible trace visualizer for post-mortem trace analysis (from BSC).
pkgver = 4.9.2.20210302
- pkgrel = 1
+ pkgrel = 2
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
@@ -12,9 +12,10 @@ pkgbase = wxparaver
depends = libxml2
depends = zlib
source = https://ftp.tools.bsc.es/wxparaver/wxparaver-4.9.2-src.tar.bz2
+ source = wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch
source = wxParaver.desktop
sha512sums = f1fbe6dbd467f38a1d50bd8108ab2174128c337206b304644f57d966d1d67b7e159a60756dce0976bdaabe10170d7862eb2bfdf10437f5d8ef599066f2fad152
+ sha512sums = a42b6481594cbab6bf4018f09bb83578cfd2fb06ad80766ece509fd48b0af76f77fd9b4b1d15129b7d1fe9b15c53e1efaea1e47bb7e76c1442f8089c0e0904b3
sha512sums = f1b000ea660765bbd454d9ae54d360233389121e54f8bcab241420b42aefa4f679735500efd43afdcd932f3a7bd339f00ff299f755a62163c1c3e34bd6920f6e
pkgname = wxparaver
-
diff --git a/PKGBUILD b/PKGBUILD
index 08553b6eef14..675eaec9e464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,24 @@
pkgname='wxparaver'
pkgdesc='Expressive powerful and flexible trace visualizer for post-mortem trace analysis (from BSC).'
pkgver='4.9.2.20210302'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(wxgtk3 webkit2gtk boost libxml2 zlib)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
+ "wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch"
"wxParaver.desktop")
sha512sums=(f1fbe6dbd467f38a1d50bd8108ab2174128c337206b304644f57d966d1d67b7e159a60756dce0976bdaabe10170d7862eb2bfdf10437f5d8ef599066f2fad152
+ a42b6481594cbab6bf4018f09bb83578cfd2fb06ad80766ece509fd48b0af76f77fd9b4b1d15129b7d1fe9b15c53e1efaea1e47bb7e76c1442f8089c0e0904b3
f1b000ea660765bbd454d9ae54d360233389121e54f8bcab241420b42aefa4f679735500efd43afdcd932f3a7bd339f00ff299f755a62163c1c3e34bd6920f6e)
prepare() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # Fix build for GCC 11
+ patch -Np1 -i "${srcdir}/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch"
+
# WORKAROUND: By default, it seems that the wxParaver depends on an existing -kernel/-api installation
cd src/wxparaver
sed -i 's|-lparaver-kernel -lparaver-api|-L../../paraver-kernel/src/.libs -L../../paraver-kernel/api/.libs -lparaver-kernel -lparaver-api|g' src/Makefile.am
diff --git a/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch b/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch
new file mode 100644
index 000000000000..4ee8c3c90cb8
--- /dev/null
+++ b/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch
@@ -0,0 +1,13 @@
+diff --git a/api/recordlist.h b/api/recordlist.h
+index 892ae6c..31e0c20 100644
+--- a/src/paraver-kernel/api/recordlist.h
++++ b/src/paraver-kernel/api/recordlist.h
+@@ -142,7 +142,7 @@ private:
+ // r1 is less than r2?
+ struct ltrecord
+ {
+- bool operator()( const RLRecord& r1, const RLRecord& r2 )
++ bool operator()( const RLRecord& r1, const RLRecord& r2 ) const
+ {
+ if ( r1.getTime() < r2.getTime() )
+ return true;