summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 656fd153a81d..4674b1576d4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = x-tile-git
pkgdesc = Allows you to select a number of windows and tile them in different ways
- pkgver = 3.0.r0.g435eef2
+ pkgver = 3.1.r0.g2e5f3db
pkgrel = 1
url = https://www.giuspen.com/x-tile
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1618e75a4662..0ec5dfa45b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fanch
# Co-Maintainer: Mark Wagie <mark.wagie at tutanota dot com>
pkgname=x-tile-git
-pkgver=3.0.r0.g435eef2
+pkgver=3.1.r0.g2e5f3db
pkgrel=1
pkgdesc="Allows you to select a number of windows and tile them in different ways"
arch=('any')
@@ -9,10 +9,10 @@ url="https://www.giuspen.com/x-tile"
license=('GPL2')
depends=('gtk3' 'python-gobject')
makedepends=('git')
-optdepends=('libappindicator-gtk3: Tray icon support') # Tray icon MIA ?
+optdepends=('libappindicator-gtk3: Tray icon support')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+https://github.com/giuspen/${pkgname%-git}.git")
+source=("git+https://github.com/giuspen/x-tile.git")
sha256sums=('SKIP')
pkgver() {
@@ -20,6 +20,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
python setup.py install --prefix=/usr --exec-prefix=/usr -f \