summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c53da60fb5dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xarexec_fuse
+ pkgdesc = Small program to mount a SquashFS xar image, required to execute xar files
+ pkgver = 19.4.22
+ pkgrel = 1
+ url = https://github.com/facebookincubator/xar
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = squashfuse
+ source = https://github.com/facebookincubator/xar/archive/19.4.22.tar.gz
+ md5sums = 993977a0e718fed66a66237c3bf2d8f0
+
+pkgname = xarexec_fuse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d78c8370330
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b56cfc24f4c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Aaron Abbott <aabmass@gmail.com>
+
+pkgname=xarexec_fuse
+pkgver=19.4.22
+pkgrel=1
+pkgdesc="Small program to mount a SquashFS xar image, required to execute xar files"
+arch=('i686' 'x86_64')
+url="https://github.com/facebookincubator/xar"
+license=('BSD')
+depends=('squashfuse')
+makedepends=('cmake')
+source=("https://github.com/facebookincubator/xar/archive/$pkgver.tar.gz")
+md5sums=('993977a0e718fed66a66237c3bf2d8f0')
+
+
+build() {
+ _cmakebuilddir="$srcdir/xar-$pkgver/build"
+ mkdir -p $_cmakebuilddir
+ cd $_cmakebuilddir
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
+ make
+}
+
+package() {
+ make -C $srcdir/xar-$pkgver/build install
+}