summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf5e129c1d90..4b2e6901625f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = xdg-utils-symlink-fix
pkgdesc = xdg-utils replacement which respects mimeapps.list being a symlink
- pkgver = 1.1.3+26+g79dcb44
- pkgrel = 2
- url = https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/49
+ pkgver = 1.2.0+beta1
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xdg/xdg-utils/-/tags/v1.2.0-beta1
arch = any
license = MIT
makedepends = docbook-xsl
@@ -22,7 +22,7 @@ pkgbase = xdg-utils-symlink-fix
optdepends = perl-x11-protocol: Perl X11 protocol used in xdg-screensaver
provides = xdg-utils
conflicts = xdg-utils
- source = git+https://gitlab.freedesktop.org/hnicke/xdg-utils-symlink-fix.git#commit=79dcb44559a5ed4b994ebc579f9575eef443e4cb
- sha256sums = SKIP
+ source = https://gitlab.freedesktop.org/xdg/xdg-utils/-/archive/v1.2.0-beta1/xdg-utils-v1.2.0-beta1.tar
+ sha256sums = 34dc0d5fb3f79557fa3821384fb18e3e382ca35f5fbca7f4be8f0d5f4cea45cc
pkgname = xdg-utils-symlink-fix
diff --git a/PKGBUILD b/PKGBUILD
index 7194676548df..2f8e430974a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
# based on package `xdg-utils`
# the intention of this package is to support `mimeapps.list` being a symlink
# this package serves as an interim solution until https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/49 is merged
+# NOTE: This package will get deprecated once v1.2.0 has been released and shipped by the 'xdg-utils' aur package
pkgname=xdg-utils-symlink-fix
-_commit=79dcb44559a5ed4b994ebc579f9575eef443e4cb
-pkgver=1.1.3+26+g79dcb44
-pkgrel=2
+_commit=f8bc7454112899413a60996b7b5d9aebfa4e6864
+_orig_pkgver=1.2.0-beta1
+pkgver="${_orig_pkgver/-/+}"
+pkgrel=1
pkgdesc="xdg-utils replacement which respects mimeapps.list being a symlink"
arch=('any')
-url="https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/49"
+url="https://gitlab.freedesktop.org/xdg/xdg-utils/-/tags/v1.2.0-beta1"
license=('MIT')
conflicts=('xdg-utils')
provides=('xdg-utils')
@@ -20,13 +22,8 @@ optdepends=('kde-cli-tools: for KDE Plasma5 support in xdg-open'
'perl-file-mimeinfo: for generic support in xdg-open'
'perl-net-dbus: Perl extension to dbus used in xdg-screensaver'
'perl-x11-protocol: Perl X11 protocol used in xdg-screensaver')
-source=("git+https://gitlab.freedesktop.org/hnicke/xdg-utils-symlink-fix.git#commit=$_commit")
-sha256sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
+source=("https://gitlab.freedesktop.org/xdg/xdg-utils/-/archive/v$_orig_pkgver/xdg-utils-v$_orig_pkgver.tar")
+sha256sums=('34dc0d5fb3f79557fa3821384fb18e3e382ca35f5fbca7f4be8f0d5f4cea45cc')
build() {
cd $pkgname #-$pkgver