summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD65
-rw-r--r--xemacs-c11.patch33
-rw-r--r--xemacs.desktop33
4 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16b136214801
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Tue Sep 20 19:14:13 UTC 2016
+pkgbase = xemacs
+ pkgdesc = An highly customizable open source text editor and application development system forked from GNU Emacs
+ pkgver = 21.5.34
+ pkgrel = 1
+ url = http://xemacs.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = xbitmaps
+ makedepends = patch
+ depends = libpng
+ depends = libtiff
+ depends = gpm
+ depends = desktop-file-utils
+ depends = libxaw
+ depends = gdbm
+ depends = giflib
+ depends = libxft
+ optdepends = xorg-fonts-75dpi: X bitmap fonts needed for the interface
+ optdepends = xorg-fonts-100dpi: X bitmap fonts needed for the interface
+ source = http://ftp.isr.tecnico.ulisboa.pt/pub/xemacs/xemacs/xemacs-21.5/xemacs-21.5.34.tar.gz
+ source = http://ftp.isr.tecnico.ulisboa.pt/pub/xemacs/xemacs/xemacs-21.5/xemacs-21.5.34.tar.gz.asc
+ source = xemacs.desktop
+ source = xemacs-c11.patch
+ sha256sums = 33cc54a6a9a45224a64b6c57c8138b5a5f0f1be368951a6d9ec8c0aec5993ee5
+ sha256sums = SKIP
+ sha256sums = 1ab2f24fa11b45512ccad2b2ce650dc27083e8ed3f3c9ed316f1c3452c91544d
+ sha256sums = ea948edf003a2fb5a8f922fea20474e1ca79cd6168fc217d07b780e4a331fe85
+
+pkgname = xemacs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0087e544272
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: juergen <juergen@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+
+pkgname=xemacs
+pkgver=21.5.34
+pkgrel=1
+pkgdesc="An highly customizable open source text editor and application development system forked from GNU Emacs"
+arch=('i686' 'x86_64')
+url="http://xemacs.sourceforge.net/"
+license=('GPL')
+depends=('libpng' 'libtiff' 'gpm' 'desktop-file-utils' 'libxaw' 'gdbm' 'giflib' 'libxft')
+optdepends=('xorg-fonts-75dpi: X bitmap fonts needed for the interface'
+ 'xorg-fonts-100dpi: X bitmap fonts needed for the interface')
+makedepends=('xbitmaps' 'patch')
+source=(http://ftp.isr.tecnico.ulisboa.pt/pub/$pkgname/$pkgname/$pkgname-21.5/$pkgname-$pkgver.tar.gz{,.asc}
+# http://ftp.xemacs.org/pub/xemacs/beta/${pkgname}-${pkgver}.tar.gz # https://en.wikipedia.org/wiki/XEmacs#XEmacs_and_GNU_Emacs
+ xemacs.desktop
+ xemacs-c11.patch)
+validpgpkeys=('AF15C7D0FFBB93E5A68DF449E0DDF50FFE38BD43') # Stephen J. Turnbull
+sha256sums=('33cc54a6a9a45224a64b6c57c8138b5a5f0f1be368951a6d9ec8c0aec5993ee5'
+ 'SKIP'
+ '1ab2f24fa11b45512ccad2b2ce650dc27083e8ed3f3c9ed316f1c3452c91544d'
+ 'ea948edf003a2fb5a8f922fea20474e1ca79cd6168fc217d07b780e4a331fe85')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i ../xemacs-c11.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --build="${CHOST}" --prefix=/usr --with-dynamic \
+ --without-postgresql --with-athena=xaw \
+ --with-database=gdbm --without-ldap \
+ --enable-menubars=lucid --enable-scrollbars=lucid \
+ --enable-widgets=athena --enable-dialogs=athena \
+ --enable-external-widget \
+ --with-jpeg --with-png --with-tiff \
+ --with-ncurses --with-pop --disable-sound \
+ --infodir=/usr/share/info \
+ --with-mule \
+ --mandir=/usr/share/man/man1 \
+ --with-xft=emacs,tabs,menubars,gauges
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -j1 prefix="${pkgdir}/usr" mandir="${pkgdir}/usr/share/man/man1" infodir="${pkgdir}/usr/share/info" install gzip-el
+
+ rm "${pkgdir}"/usr/bin/{b2m,ctags,etags}
+ rm "${pkgdir}"/usr/share/man/man1/{ctags.1,etags.1}
+
+ # fix FS#7927
+ install -d -m755 "${pkgdir}/usr/share/pixmaps"
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ ln -sf /usr/share/xemacs-${pkgver%.*}-b${pkgver##*.}/etc/xemacs-icon.xpm "${pkgdir}/usr/share/pixmaps/xemacs-icon.xpm"
+
+ # correct permissions
+ chown -R root:root "${pkgdir}"
+
+ rm "${pkgdir}"/usr/share/info/{info.info,texinfo.info-2,texinfo.info-3,cl.info,texinfo.info-1,texinfo.info,standards.info,widget.info}
+}
diff --git a/xemacs-c11.patch b/xemacs-c11.patch
new file mode 100644
index 000000000000..fef4dd56ee24
--- /dev/null
+++ b/xemacs-c11.patch
@@ -0,0 +1,33 @@
+--- src/lisp.h.orig 2014-06-05 09:02:17.000000000 -0600
++++ src/lisp.h 2015-02-09 12:30:00.000000000 -0700
+@@ -1154,6 +1154,9 @@
+
+ /* ------------------------ alignment definitions ------------------- */
+
++#if (defined (__STDC_VERSION__) && __STDC_VERSION__ < 201112L) || \
++ (defined (__cplusplus) && __cplusplus < 201103L) || \
++ (! defined (__STDC_VERSION__) && ! defined (__cplusplus))
+ /* No type has a greater alignment requirement than max_align_t.
+ (except perhaps for types we don't use, like long double) */
+ typedef union
+@@ -1163,6 +1166,7 @@
+ struct { void (*f)(void); } f;
+ struct { double d; } d;
+ } max_align_t;
++#endif
+
+ /* ALIGNOF returns the required alignment of a type -- i.e. a value such
+ that data of this type must begin at a memory address which is a
+@@ -1170,7 +1174,11 @@
+ as the type itself. */
+
+ #ifndef ALIGNOF
+-# if defined (__GNUC__) && (__GNUC__ >= 2)
++# if defined (__STDC_VERSION__) && __STDC_VERSION__ >= 201112L
++# define ALIGNOF(type) _Alignof(type)
++# elif defined (__cplusplus) && __cplusplus >= 201103L
++# define ALIGNOF(type) alignof(type)
++# elif defined (__GNUC__) && (__GNUC__ >= 2)
+ /* gcc has an extension that gives us exactly what we want. */
+ # define ALIGNOF(type) __alignof__ (type)
+ # elif ! defined (__cplusplus)
diff --git a/xemacs.desktop b/xemacs.desktop
new file mode 100644
index 000000000000..4241e1bb3000
--- /dev/null
+++ b/xemacs.desktop
@@ -0,0 +1,33 @@
+[Desktop Entry]
+Name=XEmacs Text Editor
+Name[bg]=редактор XEmacs
+Name[ca]=Editor XEmacs
+Name[cs]=Editor XEmacs
+Name[da]=XEmacs tekstredigerer
+Name[de]=XEmacs Texteditor
+Name[eo]=La redaktilo XEmakso
+Name[es]=Emacs para X
+Name[et]=Emacs X'i kasutajaliidesega
+Name[fi]=XEmacs editori
+Name[fr]=Éditeur XEmacs
+Name[hu]=XEmacs szövegszerkesztő
+Name[is]=XEmacs-ritill
+Name[it]=Emacs per X
+Name[ja]=XEmacs テキスト・エディター
+Name[mk]=Софистицираниот XEmacs уредувач
+Name[no]=XEmacs-tekstredigerer
+Name[pt]=Editor XEmacs
+Name[ro]=Editorul XEmacs
+Name[ru]=Редактор XEmacs
+Name[sk]=Editor XEmacs
+Name[sl]=Urejevalnik XEmacs
+Name[uk]=Редактор XEmacs
+GenericName=Text Editor
+Comment=Edit text
+MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
+Exec=xemacs %f
+Icon=/usr/share/pixmaps/xemacs-icon.xpm
+Type=Application
+Terminal=false
+Categories=Development;TextEditor;
+StartupWMClass=Emacs