summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD13
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25ce627a11d6..84194b3cafab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = xen
pkgver = 4.10.0
- pkgrel = 5
+ pkgrel = 6
url = http://www.xenproject.org/
changelog = ChangeLog
arch = x86_64
license = GPL2
makedepends = bin86
+ makedepends = binutils>=2.30
makedepends = bridge-utils
makedepends = brltty
makedepends = cmake
@@ -27,7 +28,6 @@ pkgbase = xen
makedepends = libpng
makedepends = lzo
makedepends = markdown
- makedepends = mingw-w64-binutils
makedepends = nasm
makedepends = ocaml-findlib
makedepends = pandoc
diff --git a/ChangeLog b/ChangeLog
index 0369162a1337..ca86c3cfda9d 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,4 +1,8 @@
2018-04-10 Maik Broemme
+ * 4.10.0-6
+ Replace 'mingw-w64-binutils' with 'binutils'
+
+2018-04-10 Maik Broemme
* 4.10.0-5
Fix missing path of '--with-system-ovmf' parameter
Fix compilation issue with glibc-2.27
diff --git a/PKGBUILD b/PKGBUILD
index 885fd147cf46..b79367767fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ _build_stubdom=${build_stubdom:-false}
pkgbase="xen"
pkgname=("xen" "xen-docs")
-pkgver=4.10.0
-pkgrel=5
+pkgver="4.10.0"
+pkgrel="6"
arch=("x86_64") # TODO What about ARM?
url="http://www.xenproject.org/"
license=("GPL2")
@@ -22,6 +22,7 @@ validpgpkeys=("23E3222C145F4475FA8060A783FE14C957E82BD9")
options=(!buildflags !strip)
makedepends=(
"bin86"
+ "binutils>=2.30"
"bridge-utils"
"brltty"
"cmake"
@@ -43,7 +44,6 @@ makedepends=(
"libpng"
"lzo"
"markdown"
- "mingw-w64-binutils"
"nasm"
"ocaml-findlib"
"pandoc"
@@ -179,12 +179,6 @@ prepare() {
msg2 'Applying misc compile fixes...'
patch -Np1 -i "${srcdir}/ocaml-unsafe-string.patch"
- # Patch EFI binary build with mingw.
- msg2 'Patching EFI build...'
- sed -i.bak '/ EFI_LD/s/LD/LD_EFI/' xen/arch/x86/Makefile
- sed -i.bak 's/LD/LD_EFI/' xen/arch/x86/efi/Makefile
- sed -i.bak '/EFI_MOUNTPOINT .*/aLD_EFI ?= $(LD)' xen/Makefile
-
# Fix Install Paths.
msg2 'Fixing installation paths...'
sed 's,/var/run,/run,g' -i tools/hotplug/Linux/locking.sh
@@ -210,7 +204,6 @@ prepare() {
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
- export LD_EFI='/usr/x86_64-w64-mingw32/bin/ld'
if [ "${_build_stubdom}" = true ] ; then
_config_stubdom='--enable-stubdom'
else