summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--0001-Use-non-legacy-icon-names.patch47
-rw-r--r--PKGBUILD48
3 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4a9b4b02b42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Jun 28 13:42:30 UTC 2017
+pkgbase = xfce4-appfinder-gtk3
+ pkgdesc = An application finder for Xfce (GTK3 version)
+ pkgver = 4.12.0
+ pkgrel = 1
+ url = http://www.xfce.org/
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = intltool
+ depends = libxfce4ui
+ depends = garcon
+ depends = hicolor-icon-theme
+ provides = xfce4-appfinder=4.12.0
+ conflicts = xfce4-appfinder
+ replaces = xfce-utils
+ source = http://archive.xfce.org/src/xfce/xfce4-appfinder/4.12/xfce4-appfinder-4.12.0.tar.bz2
+ source = 0001-Use-non-legacy-icon-names.patch
+ sha256sums = 2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567
+ sha256sums = b829103bf33d6f1ec71e1448e469b1b1df3313f887a27b7479a7cbc67e06643f
+
+pkgname = xfce4-appfinder-gtk3
+
diff --git a/0001-Use-non-legacy-icon-names.patch b/0001-Use-non-legacy-icon-names.patch
new file mode 100644
index 000000000000..afd74fe670f8
--- /dev/null
+++ b/0001-Use-non-legacy-icon-names.patch
@@ -0,0 +1,47 @@
+From 65e9020cb0d507a58e71eb31751d3eca0eb0cd59 Mon Sep 17 00:00:00 2001
+From: Evangelos Foutras <evangelos@foutrelis.com>
+Date: Thu, 8 Oct 2015 16:50:26 +0300
+Subject: [PATCH] Use non-legacy icon names
+
+gtk-find and gtk-execute are legacy icon names found in the GNOME icon
+theme, but they are not part of the Adwaita icon theme.
+
+In the GNOME icon theme, they map to edit-find and system-run via
+symlinks created by icon-naming-utils. Adwaita doesn't ship these
+symlinks. [1]
+
+[1] https://bugzilla.gnome.org/show_bug.cgi?id=729998
+---
+ data/xfce4-appfinder.desktop.in | 2 +-
+ data/xfce4-run.desktop.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/xfce4-appfinder.desktop.in b/data/xfce4-appfinder.desktop.in
+index c4bd6ca..dc34d21 100644
+--- a/data/xfce4-appfinder.desktop.in
++++ b/data/xfce4-appfinder.desktop.in
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Version=1.0
+ Exec=xfce4-appfinder
+-Icon=gtk-find
++Icon=edit-find
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+diff --git a/data/xfce4-run.desktop.in b/data/xfce4-run.desktop.in
+index 9611cd5..a888753 100644
+--- a/data/xfce4-run.desktop.in
++++ b/data/xfce4-run.desktop.in
+@@ -2,7 +2,7 @@
+ Version=1.0
+ Type=Application
+ Exec=xfce4-appfinder --collapsed
+-Icon=gtk-execute
++Icon=system-run
+ StartupNotify=true
+ Terminal=false
+ Categories=Utility;X-XFCE;X-Xfce-Toplevel;
+--
+2.6.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5ce94111203
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id$
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=xfce4-appfinder
+pkgname=${_pkgname}-gtk3
+pkgver=4.12.0
+pkgrel=1
+pkgdesc="An application finder for Xfce (GTK3 version)"
+arch=('i686' 'x86_64')
+url="http://www.xfce.org/"
+license=('GPL2')
+groups=('xfce4')
+depends=('libxfce4ui' 'garcon' 'hicolor-icon-theme')
+makedepends=('intltool')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+replaces=('xfce-utils')
+source=(http://archive.xfce.org/src/xfce/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.bz2
+ 0001-Use-non-legacy-icon-names.patch)
+sha256sums=('2ad4a58019a76a6b64a816050db25f96854917c2f2e89d6a9df6c18e6c84c567'
+ 'b829103bf33d6f1ec71e1448e469b1b1df3313f887a27b7479a7cbc67e06643f')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ patch -Np1 -i ../0001-Use-non-legacy-icon-names.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --enable-gtk3 \
+ --disable-static \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: