summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 439356061283..ebef547b379b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = xfce4-hotcorner-plugin-git
pkgdesc = Provides an easy way to set up hot corners in the Xfce desktop environment
- pkgver = 0.0.2.r1.g996f76a
+ pkgver = 0.0.4.r8.gfea4b50
pkgrel = 1
- url = https://github.com/brianhsu/xfce4-hotcorner-plugin
+ url = https://github.com/christopherkobayashi/xfce4-hotcorner-plugin
install = xfce4-hotcorner-plugin.install
arch = i686
arch = x86_64
groups = xfce4
license = GPL2
- makedepends = cmake
- makedepends = xfce4-dev-tools
- makedepends = git
+ makedepends = xfce4-panel
+ makedepends = libwnck3
+ makedepends = libnotify
+ makedepends = gtk3
+ makedepends = intltool
depends = xfce4-panel
depends = libwnck3
+ provides = xfce4-hotcorner-plugin
conflicts = xfce4-hotcorner-plugin
- source = xfce4-hotcorner-plugin::git+https://github.com/brianhsu/xfce4-hotcorner-plugin.git
+ source = xfce4-hotcorner-plugin::git+https://github.com/christopherkobayashi/xfce4-hotcorner-plugin.git
sha256sums = SKIP
pkgname = xfce4-hotcorner-plugin-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 66eef2d51d4b..d5376d788daa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
_pkgname=xfce4-hotcorner-plugin
pkgname="${_pkgname}-git"
-pkgver=0.0.2.r1.g996f76a
+pkgver=0.0.4.r8.gfea4b50
pkgrel=1
pkgdesc="Provides an easy way to set up hot corners in the Xfce desktop environment"
arch=('i686' 'x86_64')
license=('GPL2')
-url="https://github.com/brianhsu/xfce4-hotcorner-plugin"
+url="https://github.com/christopherkobayashi/${_pkgname}"
groups=("xfce4")
depends=('xfce4-panel' 'libwnck3')
-makedepends=('cmake' 'xfce4-dev-tools' 'git')
-provides=("${_pgname}")
+makedepends=('xfce4-panel' 'libwnck3' 'libnotify' 'gtk3' 'intltool')
+provides=("${_pkgname}")
conflicts=("${_pkgname}")
install="${_pkgname}.install"
-source=("${_pkgname}::git+https://github.com/brianhsu/${_pkgname}.git")
+source=("${_pkgname}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
@@ -24,11 +24,10 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr
+ ./configure --prefix=/usr && make
}
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="$pkgdir" install
}
-