summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
-rw-r--r--undefined-symbol.patch65
3 files changed, 84 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e7b27666be6..e38830f08b86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xfce4-places-plugin
pkgdesc = Places menu plugin for the Xfce panel
pkgver = 1.7.0
- pkgrel = 3
+ pkgrel = 4
url = http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
arch = i686
arch = x86_64
@@ -11,8 +11,10 @@ pkgbase = xfce4-places-plugin
depends = xfce4-panel
source = http://archive.xfce.org/src/panel-plugins/xfce4-places-plugin/1.7/xfce4-places-plugin-1.7.0.tar.bz2
source = mounts.patch
+ source = undefined-symbol.patch
sha256sums = 4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f
sha256sums = 0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb
+ sha256sums = 459a303dee55f6d723bf43e91fb8eebf209b59ee2e42bd1772e34f7518cf73aa
pkgname = xfce4-places-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 86a56c1b415c..e408b0fe2d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=xfce4-places-plugin
pkgver=1.7.0
-pkgrel=3
+pkgrel=4
pkgdesc="Places menu plugin for the Xfce panel"
arch=('i686' 'x86_64')
url="http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
@@ -11,27 +11,32 @@ license=('GPL2')
depends=('libnotify' 'xfce4-panel')
makedepends=('intltool')
source=("http://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.bz2"
- "mounts.patch")
+ "mounts.patch"
+ "undefined-symbol.patch")
sha256sums=('4175c614749abbb5bcf6f49c88125fb0dd36db69f4c374df23563907b16e2c3f'
- '0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb')
+ '0f772f067bff34dd94a473b192494335eb73c4c3d867e4f5bf81828f825d95eb'
+ '459a303dee55f6d723bf43e91fb8eebf209b59ee2e42bd1772e34f7518cf73aa')
prepare() {
cd "$pkgname-$pkgver"
# Show other mounts that are non disks (eg. NFS)
patch -Np1 -i "${srcdir}/mounts.patch"
+
+ # Bug 11939
+ patch -Np1 -i "${srcdir}/undefined-symbol.patch"
}
build() {
cd "$pkgname-$pkgver"
- # add compatibility for inline functions
- CFLAGS=-fgnu89-inline ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --disable-static \
- --disable-debug
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-debug
make
}
package() {
diff --git a/undefined-symbol.patch b/undefined-symbol.patch
new file mode 100644
index 000000000000..3fe7be23d3a3
--- /dev/null
+++ b/undefined-symbol.patch
@@ -0,0 +1,65 @@
+From 94d583d0ba257cdc96cde5794ebb7d38001ae3a5 Mon Sep 17 00:00:00 2001
+From: Andrzej <ndrwrdck@gmail.com>
+Date: Tue, 7 Jul 2015 22:26:51 +0100
+Subject: Bug 11939: xfce4-places-plugin 1.7.0 crashes with undefined symbol
+
+Patch from Fedora. Submitted by Kevin Fenzi.
+
+diff --git a/panel-plugin/model.h b/panel-plugin/model.h
+index 06d9d6f..043e391 100644
+--- a/panel-plugin/model.h
++++ b/panel-plugin/model.h
+@@ -36,13 +36,13 @@ struct _PlacesBookmarkAction
+ void (*finalize) (PlacesBookmarkAction *self);
+ };
+
+-inline PlacesBookmarkAction*
++extern inline PlacesBookmarkAction*
+ places_bookmark_action_create(gchar *label);
+
+-inline void
++extern inline void
+ places_bookmark_action_destroy(PlacesBookmarkAction*);
+
+-inline void
++extern inline void
+ places_bookmark_action_call(PlacesBookmarkAction*);
+
+ /* Places Bookmark */
+@@ -70,10 +70,10 @@ struct _PlacesBookmark
+ void (*finalize) (PlacesBookmark *self);
+ };
+
+-inline PlacesBookmark*
++extern inline PlacesBookmark*
+ places_bookmark_create(gchar *label);
+
+-inline void
++extern inline void
+ places_bookmark_destroy(PlacesBookmark *bookmark);
+
+ /* Places Bookmark Group */
+@@ -86,16 +86,16 @@ struct _PlacesBookmarkGroup
+ gpointer priv;
+ };
+
+-inline GList*
++extern inline GList*
+ places_bookmark_group_get_bookmarks(PlacesBookmarkGroup*);
+
+-inline gboolean
++extern inline gboolean
+ places_bookmark_group_changed(PlacesBookmarkGroup*);
+
+-inline PlacesBookmarkGroup*
++extern inline PlacesBookmarkGroup*
+ places_bookmark_group_create();
+
+-inline void
++extern inline void
+ places_bookmark_group_destroy(PlacesBookmarkGroup*);
+
+ #endif
+--
+cgit v0.10.1
+