summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ec611c51f18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xfce4-volumed-pulse-git
+ pkgdesc = A volume keys control daemon for Xfce using pulseaudio
+ pkgver = r83.faec2e8
+ pkgrel = 1
+ url = https://git.xfce.org/apps/xfce4-volumed-pulse
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = xfce4-dev-tools
+ depends = libnotify
+ depends = pulseaudio
+ depends = libkeybinder3
+ depends = xfconf
+ optdepends = xfce4-notifyd: for OSD notifications
+ conflicts = xfce4-volumed
+ conflicts = xfce4-volumed-pulse
+ replaces = xfce4-volumed
+ replaces = xfce4-volumed-pulse
+ source = xfce4-volumed-pulse::git://git.xfce.org/apps/xfce4-volumed-pulse
+ sha256sums = SKIP
+
+pkgname = xfce4-volumed-pulse-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8730ab389101
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jordy van Wolferen <jordy@jvwdev.nl>
+
+pkgname=xfce4-volumed-pulse-git
+pkgdesc='A volume keys control daemon for Xfce using pulseaudio'
+pkgver=r83.faec2e8
+pkgrel=1
+arch=('x86_64')
+license=('GPL3')
+url="https://git.xfce.org/apps/xfce4-volumed-pulse"
+
+conflicts=('xfce4-volumed' 'xfce4-volumed-pulse')
+replaces=('xfce4-volumed' 'xfce4-volumed-pulse')
+
+depends=('libnotify' 'pulseaudio' 'libkeybinder3' 'xfconf')
+optdepends=('xfce4-notifyd: for OSD notifications')
+makedepends=('git' 'xfce4-dev-tools')
+
+source=("${pkgname%-git}::git://git.xfce.org/apps/xfce4-volumed-pulse")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
+}