summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--COPYING.RUNTIME53
-rw-r--r--PKGBUILD93
-rw-r--r--expose-cargs-and-largs-makefile.patch20
4 files changed, 79 insertions, 109 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a5b76c305e1..6f9e02326552 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = xmlada
- pkgdesc = An XML parser for Ada94
- pkgver = 2020
- pkgrel = 1
- url = https://github.com/AdaCore/xmlada/
+ pkgdesc = An XML parser for Ada95.
+ pkgver = 24.0w
+ pkgrel = 2
+ epoch = 1
+ url = https://github.com/AdaCore/xmlada
arch = i686
arch = x86_64
license = GPL3
license = custom
- makedepends = gprbuild-bootstrap
- depends = gcc-ada
+ makedepends = gprbuild
+ makedepends = gcc-ada
conflicts = xmlada-git
- source = xmlada-2020-20200429-19A99-src.tar.gz::https://community.download.adacore.com/v1/c799502295baf074ad17b48c50f621879c392c57?filename=xmlada-2020-20200429-19A99-src.tar.gz
+ source = https://github.com/charlie5/archlinux-gnatstudio-support/raw/main/gnatstudio-sources/xmlada-24.0w-20230324-1684A-src.tar.gz
source = expose-cargs-and-largs-makefile.patch
- source = COPYING.RUNTIME
- sha1sums = c799502295baf074ad17b48c50f621879c392c57
- sha1sums = 9b65cc99453fd15bdb7c49a32e6f76922ec904bd
- sha1sums = 44a4a599d98b4ec6d63051103de2fd177f43f67a
+ sha256sums = c243de68f3f7c0f5e8a23d24ab0725d038f4dd2b7798855a3b91b574e44e2dc1
+ sha256sums = 7543e5fa8f2b0b400b937b0b3bb27b46b263a3cd7b17f00f6f9c6b3905729610
pkgname = xmlada
-
diff --git a/COPYING.RUNTIME b/COPYING.RUNTIME
deleted file mode 100644
index 637f433521d5..000000000000
--- a/COPYING.RUNTIME
+++ /dev/null
@@ -1,53 +0,0 @@
-GCC RUNTIME LIBRARY EXCEPTION
-
-Version 3.1, 31 March 2009
-
-Copyright (c) 2009 Free Software Foundation, Inc. <http://fsf.org/>
-
-Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.
-
-This GCC Runtime Library Exception ("Exception") is an additional permission under section 7 of the GNU General Public License,
-version 3 ("GPLv3"). It applies to a given file (the "Runtime Library") that bears a notice placed by the copyright holder of
-the file stating that the file is governed by GPLv3 along with this Exception.
-
-When you use GCC to compile a program, GCC may combine portions of certain GCC header files and runtime libraries with the
-compiled program. The purpose of this Exception is to allow compilation of non-GPL (including proprietary) programs to
-use, in this way, the header files and runtime libraries covered by this Exception.
-
-0. Definitions.
-
-A file is an "Independent Module" if it either requires the Runtime Library for execution after a Compilation
-Process, or makes use of an interface provided by the Runtime Library, but is not otherwise based on the Runtime Library.
-
-"GCC" means a version of the GNU Compiler Collection, with or without modifications, governed by version 3
-(or a specified later version) of the GNU General Public License (GPL) with the option of using any subsequent
-versions published by the FSF.
-
-"GPL-compatible Software" is software whose conditions of propagation, modification and use would permit combination
-with GCC in accord with the license of GCC.
-
-"Target Code" refers to output from any compiler for a real or virtual target processor architecture, in executable
-form or suitable for input to an assembler, loader, linker and/or execution phase. Notwithstanding that, Target Code
-does not include data in any format that is used as a compiler intermediate representation, or used for producing a
-compiler intermediate representation.
-
-The "Compilation Process" transforms code entirely represented in non-intermediate languages designed for human-written
-code, and/or in Java Virtual Machine byte code, into Target Code. Thus, for example, use of source code generators and
-preprocessors need not be considered part of the Compilation Process, since the Compilation Process can be understood as
-starting with the output of the generators or preprocessors.
-
-A Compilation Process is "Eligible" if it is done using GCC, alone or with other GPL-compatible software, or if it is
-done without using any work based on GCC. For example, using non-GPL-compatible Software to optimize any GCC
-intermediate representations would not qualify as an Eligible Compilation Process.
-
-1. Grant of Additional Permission.
-
-You have permission to propagate a work of Target Code formed by combining the Runtime Library with Independent Modules,
-even if such propagation would otherwise violate the terms of GPLv3, provided that all Target Code was generated by
-Eligible Compilation Processes. You may then convey such a combination under terms of your choice, consistent with the
-licensing of the Independent Modules.
-
-2. No Weakening of GCC Copyleft.
-
-The availability of this Exception does not imply any general presumption that third-party software is unaffected by
-the copyleft requirements of the license of GCC.
diff --git a/PKGBUILD b/PKGBUILD
index 4ee6667e5df9..d62bc9fc14ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,76 @@
-# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+# Maintainer: Rod Kay <rodakay5 at gmail dot com>
+
# Contributor: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
# Contributor: Earnestly <zibeon AT googlemail.com>
pkgname=xmlada
-pkgver=2020
-_upstream_ver=2020-20200429-19A99
-pkgrel=1
-pkgdesc="An XML parser for Ada94"
-arch=('i686' 'x86_64')
-url="https://github.com/AdaCore/xmlada/"
-license=('GPL3' 'custom')
-depends=('gcc-ada')
-makedepends=('gprbuild-bootstrap')
-conflicts=("$pkgname-git")
-
-_checksum=c799502295baf074ad17b48c50f621879c392c57
-source=("$pkgname-$_upstream_ver-src.tar.gz::https://community.download.adacore.com/v1/${_checksum}?filename=$pkgname-$_upstream_ver-src.tar.gz"
- 'expose-cargs-and-largs-makefile.patch'
- 'COPYING.RUNTIME')
-sha1sums=("$_checksum"
- '9b65cc99453fd15bdb7c49a32e6f76922ec904bd'
- '44a4a599d98b4ec6d63051103de2fd177f43f67a')
-
-prepare() {
- cd "$srcdir/$pkgname-$_upstream_ver-src"
- patch -Np1 -i "$srcdir/expose-cargs-and-largs-makefile.patch"
+pkgdesc='An XML parser for Ada95.'
+pkgver=24.0w
+pkgrel=2
+epoch=1
+
+arch=(i686 x86_64)
+url=https://github.com/AdaCore/xmlada
+license=(GPL3 custom)
+
+#makedepends=(gprbuild-bootstrap gcc-ada)
+makedepends=(gprbuild gcc-ada)
+conflicts=($pkgname-git)
+
+source=(https://github.com/charlie5/archlinux-gnatstudio-support/raw/main/gnatstudio-sources/$pkgname-$pkgver-20230324-1684A-src.tar.gz
+ expose-cargs-and-largs-makefile.patch)
+
+sha256sums=(c243de68f3f7c0f5e8a23d24ab0725d038f4dd2b7798855a3b91b574e44e2dc1
+ 7543e5fa8f2b0b400b937b0b3bb27b46b263a3cd7b17f00f6f9c6b3905729610)
+
+_xmlada_src=$pkgname-$pkgver-20230428-16463-src
+
+
+prepare()
+{
+ cd $srcdir/$_xmlada_src
+
+ patch -Np0 -i $srcdir/expose-cargs-and-largs-makefile.patch
}
-build() {
- cd "$srcdir/$pkgname-$_upstream_ver-src"
- ./configure --prefix=/usr --libexecdir=/lib --enable-shared
+
+build()
+{
+ cd $srcdir/$_xmlada_src
+
+ ./configure --prefix=/usr \
+ --libexecdir=/lib \
+ --enable-shared \
+ --enable-build=Production
+
+ # Rid flags not used by Ada.
+ #
+ CFLAGS="${CFLAGS//-Wformat}"
+ CFLAGS="${CFLAGS//-Werror=format-security}"
# Make using a single job (-j1) to avoid the same file being compiled at the same time.
+ #
make -j1 GPRBUILD_OPTIONS=-R
}
-package() {
- cd "$srcdir/$pkgname-$_upstream_ver-src"
+
+package()
+{
+ cd $srcdir/$_xmlada_src
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
- make -j1 prefix="$pkgdir/usr" install
+ #
+ make -j1 prefix=$pkgdir/usr install
+
+ # Install the licenses.
+ #
+ install -D -m644 \
+ COPYING3 \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING3
# Install the custom license.
- install -D -m644 \
- "$srcdir/COPYING.RUNTIME" \
- "$pkgdir/usr/share/licenses/${pkgname}/COPYING.RUNTIME"
-}
+ install -D -m644 \
+ COPYING.RUNTIME \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME
+} \ No newline at end of file
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
index ee2662a64387..8cbe752d6cab 100644
--- a/expose-cargs-and-largs-makefile.patch
+++ b/expose-cargs-and-largs-makefile.patch
@@ -1,8 +1,6 @@
-diff --git a/Makefile.in b/Makefile.in
-index c6327d2..3355762 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -51,14 +51,22 @@ all: static
+--- Makefile.in-orig 2022-09-28 16:33:19.000000000 +1000
++++ Makefile.in 2022-11-15 21:15:27.002332097 +1100
+@@ -68,14 +68,22 @@
install: install-clean install-static
endif
@@ -15,16 +13,16 @@ index c6327d2..3355762 100644
+endif
+
static:
-- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr
-+ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA}
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA} $(CARGS) $(LARGS)
shared relocatable:
-- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr
-+ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA}
++ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA} $(CARGS) $(LARGS)
static-pic:
-- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr
-+ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA}
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA} $(CARGS) $(LARGS)
# Rebuild the tests (and not the XML/Ada code itself)
test: force