summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
-rw-r--r--nycli.conf23
-rw-r--r--xmms2swi-nycli.patch55
4 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e06b2afdd64f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 4.2.0
+# Sun Feb 1 05:44:31 UTC 2015
+pkgbase = xmms2swi
+ pkgdesc = An XMMS2 Web Interface Client
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://xmms2swi.sourceforge.net/
+ arch = x86
+ arch = x86_64
+ license = GPL
+ makedepends = patch
+ depends = xmms2
+ depends = php>=5
+ optdepends = apache: A high performance Unix-based HTTP server
+ optdepends = lighttpd: A secure, fast, compliant and very flexible web-server
+ optdepends = thttpd: Simple, small, portable, fast, and secure HTTP server
+ optdepends = nginx: Lightweight HTTP server and IMAP/POP3 proxy server
+ source = http://sourceforge.net/projects/xmms2swi/files/xmms2swi/xmms2swi-0.5/xmms2swi-0.5.tar.gz/download
+ source = nycli.conf
+ source = xmms2swi-nycli.patch
+ md5sums = 72947216e2ba857af272c28f077e6757
+ md5sums = c64fb15d15507ebcc71f6bd1d617ddeb
+ md5sums = 913d45b5bea7ee44b1872254f9808d6b
+
+pkgname = xmms2swi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2f54750a81a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# A small web interface for xmms2 server
+# Maintainer: Ivan Agarkov <ivan.agarkov@gmail.com>
+pkgname=("xmms2swi")
+pkgver=("0.5")
+pkgrel=("1")
+pkgdesc=("An XMMS2 Web Interface Client")
+arch=("x86" "x86_64")
+url="http://xmms2swi.sourceforge.net/"
+license=("GPL")
+makedepends=("patch")
+depends=("xmms2" "php>=5" )
+optdepends=(
+ "apache: A high performance Unix-based HTTP server"
+ "lighttpd: A secure, fast, compliant and very flexible web-server"
+ "thttpd: Simple, small, portable, fast, and secure HTTP server"
+ "nginx: Lightweight HTTP server and IMAP/POP3 proxy server"
+)
+source=("http://sourceforge.net/projects/xmms2swi/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz/download"
+ "nycli.conf"
+ "xmms2swi-nycli.patch")
+md5sums=('72947216e2ba857af272c28f077e6757'
+ 'c64fb15d15507ebcc71f6bd1d617ddeb'
+ '913d45b5bea7ee44b1872254f9808d6b')
+build() {
+ cd "$pkgname"
+ patch -p1 < ../xmms2swi-nycli.patch
+}
+
+package() {
+ mkdir -p "$pkgdir/srv/http/xmms2swi"
+ install -o http -g http -m 0644 -D nycli.conf "$pkgdir/srv/http/.config/xmms2/clients/nycli.conf"
+ ( cd "$pkgname"; tar cf - . ) | (cd "$pkgdir/srv/http/xmms2swi"; tar xf -)
+ chown -R http:http "$pkgdir/srv/http/xmms2swi"
+}
diff --git a/nycli.conf b/nycli.conf
new file mode 100644
index 000000000000..8fa19df1203b
--- /dev/null
+++ b/nycli.conf
@@ -0,0 +1,23 @@
+[main]
+
+PROMPT=xmms2>
+SERVER_AUTOSTART=false
+AUTO_UNIQUE_COMPLETE=true
+SHELL_START_MESSAGE=true
+PLAYLIST_MARKER=->
+GUESS_PLS=false
+CLASSIC_LIST=true
+CLASSIC_LIST_FORMAT=${artist} - ${title}
+HISTORY_FILE=
+STATUS_FORMAT=${artist} - ${title} (${minutes}:${seconds})
+
+[alias]
+
+ls = list
+clear = playlist clear
+quit = server shutdown
+repeat = seek 0
+mute = server volume 0
+scap = stop ; playlist clear ; add $@ ; play
+status = current -r 1
+addpls = add -f -P $@
diff --git a/xmms2swi-nycli.patch b/xmms2swi-nycli.patch
new file mode 100644
index 000000000000..684485fa56db
--- /dev/null
+++ b/xmms2swi-nycli.patch
@@ -0,0 +1,55 @@
+diff -Naur xmms2swi/config.ini new/config.ini
+--- xmms2swi/config.ini 2008-08-28 14:40:21.000000000 +0400
++++ new/config.ini 2015-02-01 08:38:37.000000000 +0300
+@@ -3,7 +3,7 @@
+
+ [access/core]
+ ;; for XMMS2SWIAccessCheckModule
+-enabled=true
++enabled=false
+ mode=ip
+
+ [access/ip]
+@@ -11,9 +11,12 @@
+ filter=127.0.0.1,192.168.1.*
+
+ [browser/mount]
+-disk_d=disk,Mp3 on disk d:,/mnt/m2/mp3
+-local=disk,local media,/home/media/mp3
++home=disk,home dir,/home/user
++local=disk,some disk,/mnt/hdd
+
+ [browser/core]
+ enabled=true
+-types=mp3,mpc,ogg,wma
+\ No newline at end of file
++types=mp3,mpc,ogg,wma
++
++[core/path]
++xmms_path=tcp://127.0.0.1:9667
+diff -Naur xmms2swi/xmms2.php new/xmms2.php
+--- xmms2swi/xmms2.php 2008-08-18 12:28:52.000000000 +0400
++++ new/xmms2.php 2015-02-01 08:34:25.000000000 +0300
+@@ -25,7 +25,6 @@
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+-
+ class XMMS2
+ {
+ public function play()
+diff -Naur xmms2swi/xmms2swi.php new/xmms2swi.php
+--- xmms2swi/xmms2swi.php 2008-08-18 12:29:11.000000000 +0400
++++ new/xmms2swi.php 2015-02-01 08:34:25.000000000 +0300
+@@ -81,7 +81,10 @@
+ public function __construct(XMMS2SWIConfigInterface $config)
+ {
+ $this->config = $config;
+-
++ if($this->config->sectionExist('core/path')) {
++ $xmms_path = $this->config->get('core/path', 'xmms_path');
++ putenv("XMMS_PATH=$xmms_path");
++ }
+ require_once('xmms2.php');
+ $this->xmms2 = new XMMS2();
+ $this->modules = array();